Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2003, 10:51 AM
Registered User
 
Join Date: Feb 2003
Location: Durham, NC
Posts: 158
2000 ML320 Drivers Side Front Wheel Bearing?

I am hearing a grinding type bearing noise that appears to be coming from the drivers side front wheel bearing on my 2000 ML320. The noise is constant going down the highway and gets louder if I am turning right. The noise also quiets down when I let off on the accelerator and coast as when you take the load off the problem component. Also, when turning to the right there is somewhat of a shudder that you feel through the steering wheel. I think it is the drivers side wheel bearing and am wondering if anyone else has experienced this problem since most of the problems on the ML always end up being "common occurences." When I sit in the drivers seat the noise is louder than when I sit in the passenger seat so it appears to be coming from the drivers side. The only other thing that I can think of that would be causing this noise would be the transfer case ( I sure hope not since the vehicle is now out-of-warranty).

I hate to think of going back to the dealer again since I have already been there 3 times in the last month. I am getting to know these people on a first name basis! In my opinion, the quality of the Mercedes product is going down the sewer and this will probably be my last one. Sooner or later I am going to have to bite the bullet and dump this thing and take my losses. I do not generally like American vehicles, but even these are less problematic during the first 60,000 miles than my ML320 has been with now only 39,500 miles.

To summarize, the design is Mercedes but the quality of the components is cheap - cheap - cheap. Mercedes will not survive if it keeps turning out products like this.
Reply With Quote
  #2  
Old 12-11-2003, 08:26 AM
Registered User
 
Join Date: Feb 2003
Location: Durham, NC
Posts: 158
It was the front wheel bearings

I took my 2000 ML320 with 39,600 miles in to the MB dealership yesterday. The problem turned out to be the front wheel bearings. Yes, I said "bearings" , both of them. I have never seen another post concerning replacement of this item in an ML and the dealership said they never see this anymore in the MB passenger cars but have seen this in the ML (especially the drivers side front).
Reply With Quote
  #3  
Old 12-11-2003, 08:38 AM
azinn's Avatar
Senior Member
 
Join Date: Jun 2003
Location: The Sunshine State
Posts: 487
Thanks for the heads up. Like the harmonic balancer problem, a lot of folks wouldn't know about these potential problems if not for the input in these forums.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page