Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-21-2000, 08:54 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
On my 108, passenger side, there is a piece which looks somewhat like a tie rod. This piece sits just forward of the steering damper, and attaches to the same mount as the damper on the frame. The other end of this rod attaches to the frame crossover, at about the halfway point.

What is it, and what is the function of this piece? I ask, because while doing my oil change today, I noticed this piece was broken clean through about 2 inches from the dual mount with the damper. Since it is not mounted to any moving parts, I assume it is simply some sort of stiffener for frame integrity. I have noticed no difference in the handling of the car lately, nor have I heard any strange noises (knocking, bumping etc, from the steering).

I did not notice this defect during the last oil change 3,300 miles ago. I did recently clean the underside, removing many years of built up crud (this really made things stand out), so it is possible this has been broken for some time.

I'll be checking my local MB Tech's parts cars for a replacement.


BTW, I was out of town for two weeks, and came back to seven pages of new messages!!!! Took me two days to read through them.
------------------
Mike Tangas
73 280 SEL 4.5

[This message has been edited by MikeTangas (edited 11-21-2000).]
Reply With Quote
  #2  
Old 11-27-2000, 01:16 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
I now know what the part is - it is the front stabilizer bar. Unfortunately the one from the parts car at the local MB Tech has already been pulled, so the search begins.

According to Franz, the bar could have broken due to hitting a solid object (usually results in bending the bar) or worn/bad sub frame mounts. I will be checking those out when I get a replacement stabilizer.

------------------
Mike Tangas
73 280 SEL 4.5
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is thge throttle linkage supposed to be this way? JHZR2 Diesel Discussion 3 01-14-2004 05:52 PM
124 Mono-Wiper linkage failure Zeitgeist Diesel Discussion 7 12-10-2003 10:05 PM
82 300SD throttle linkage and cruise control waybomb Diesel Discussion 0 12-28-2002 06:52 PM
Lots of Slop in 1985 300SD Accelerator Linkage downeyjc Diesel Discussion 2 07-25-2001 10:59 PM
Broken Linkage? MikeTangas Vintage Mercedes 11 12-01-2000 09:02 PM



All times are GMT -4. The time now is 09:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page