Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2004, 10:41 PM
JGHowland's Avatar
Registered User
 
Join Date: Nov 2004
Location: Corning NY
Posts: 2
Question 93 300E Right Rear Window Issue - parts ID

I have a 93 300E with a rear window failure - after removing the door panel, I found some parts at the bottom of the door (see attached picture), along with a loose cable. The window didn't go up or down until I cleared a cable jam, now it won't stay up without a jam between window and frame.

Can anyone identify these parts?

How can I get the cable back where it belongs and how do these parts fit in?

Thanks for any assistance,
jgh
Attached Thumbnails
93 300E Right Rear Window Issue - parts ID-window_parts.jpg  
Reply With Quote
  #2  
Old 11-12-2004, 12:51 AM
Registered User
 
Join Date: Aug 2003
Location: Orlando
Posts: 79
These are off the window regulator.As you look at your window regulator - the clip is located on the part that slides up and down the rail. It is used to hold the tension of the cable ends together and allows your window to go up and down. You may have to bend the ends of the clip to make sure that it fits back snug. Now expect to have to play with this as you try to get the two ends of the cable into the clip and then the clip with the tensioned cable back into the slide. The best way to analigize it is to picture the end of a bicycle brake cable being pressed fit into the brake lever on the handle bar.

I believe the little white item goes inside the white square plastic part on the rail. The back clips into place and can be opened to reinstall.

On a different note - this deals with windows that go partially up and stops. You may notice many threads with people having window symptoms of only going part of the way up - but the motor seems fine and the switch is ok.
As you have the regu;ator off the car take a look at the aluminum part that is attached to the regulator jaw by way of a rivet.

I had the same problem. So while I had ithe window regulator out I reconected the power and observed the action of the window regulator jaw going up and down and sure enough it went 1/2 ro 2/3 way up and stopped. Motor was fine.

I observed that the larger aluminum piece connected by the rivet is supposed to hook onto the piece that rides up and down the track. I discovered that the aluminum was slightly bent (hardly noticeable) and allowed it to swing off the other piece and out of position. Nothing actually broken but while the regulator went to the top the alignment was thrown off and the window would not make it to the top.

I simply put it into position and slighlt bent the ends of this aluminum to make sure that it remained in place and no more problems for the past year.

Wish I could figure out how to attach pictures I took.

Good luck.
Reply With Quote
  #3  
Old 11-12-2004, 08:01 AM
Registered User
 
Join Date: Dec 2002
Location: New Castle County, DE
Posts: 1,003
JG, I have a working regulator that needs a motor (had water damage) from the right rear door of a 1987 300E. $5 plus UPS. you would need to check if its the same. Contact me if interested and further description. Hanno
__________________
Hanno
'79 6.9 Sold (after 27 years of ownership)
'83 280SL, 5 spd.
'94 E320 Sdn. 5 spd conversion
'95 E320 TE Wagon, '95 E320 sedan
'02 E320 Sdn.(on loan to mom!)
'87 300E (5 spd. conversion) Sold
Reply With Quote
  #4  
Old 11-23-2004, 11:45 PM
Registered User
 
Join Date: Nov 2002
Location: Ma
Posts: 23
help

Hello,
I just found the same thing with my 93 300e and cannot fugure out how to put the parts back in. How did you do with yours

Phil
Reply With Quote
  #5  
Old 11-25-2004, 12:17 PM
JGHowland's Avatar
Registered User
 
Join Date: Nov 2004
Location: Corning NY
Posts: 2
Fixed...

Quote:
Originally Posted by Phil1347
Hello,
I just found the same thing with my 93 300e and cannot fugure out how to put the parts back in. How did you do with yours

Phil
Thanks to git0 for your advice. To complete the fix, I pulled the regulator out of the door, then had to open the motor where the line spools - the wire line came off the tracks on the motor spool. While open, I threaded the lines thru their pulleys, used a pair of pliers and a little elbow grease to place the cable ends back into the keeper. The long thin piece clips over the two cable ends, and the cap on the regulator closes OVER that piece to hold it in place. Then I placed the small platic piece in the resulting slot - it appears to act as a lock. Reinstalled regulator and window works like it's supposed to.

Good luck...
Reply With Quote
  #6  
Old 11-25-2004, 01:50 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
When the regulator gets to the position of coming apart its life is over. Replace it.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page