Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-28-2005, 08:10 PM
Registered User
 
Join Date: Sep 2001
Posts: 79
Cold hesitation is normal??

I finallly got my 85 380sl running almost like new.. I replaced (cap, rotor, wires, plugs, coil, ICV, CSV, OLV relay, fuel pump.) and still had the cold start and running rough problem. Finally bought the car to a mechanic recommended by the forum. It turned out to be a mixture problem. He adjusted the 3mm screw and run prefectly. However, after I get the car started, I press on the gas and it also stalled. Let go the gas and idle prefect. I asked him and he said it is normal during the spring time (50'-60' deg) Once the weather gets warmer, the hesitation will be gone.. He also said if I replaced the warm up regulator, it may improve a little bit.. Anything else I can do?????
thanks
__________________
Tony S....
98 MB E320
85 MB 380SL
01 Subraru Impreza (sold)
04 Toyota Highlander
82 25' W/A Cruisers
Reply With Quote
  #2  
Old 04-29-2005, 08:24 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Exclamation

Cold hesitation on that engine can be elimated with the correct fuel pressure adjustments! ON any CIS engine with warm-up regulator the fuel pressure MAP is temp controlled and must be with-in Bosch specs thru-out the warm-up process!

Many times a new warm-up regulator is required, BUT many times even a new regulator will require slight adjustment.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E low idle when cold pentoman Tech Help 2 11-13-2004 08:02 AM
300 TE cold start problem whutchens Tech Help 11 03-05-2004 04:03 AM
240D shakes wicked on cold starts! Normal? ktang Diesel Discussion 2 01-06-2003 12:19 PM
300E cold shift problem from 1st gear when cold !!! Witoldma Tech Help 1 12-11-2002 05:38 AM
DESPERATE - Please help! cold start/running problems agupta Tech Help 7 07-27-2001 10:19 PM



All times are GMT -4. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page