Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2005, 08:44 PM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
99 SL500 won't start after warm

The car started normally when cold drove to the bank 2miles away got back in the car it turn over but it wouldn't start let it sit for 15 minutes it started again drove home.started again next day normal it was on fuel reserve so I tought contaminated fuel in the bottom of the tank,also suspicion of clogged fuel filter drove aprox a mile parked it shut it off 10 min later try to started it just turn over waited again and bingo, remove fuel filter looking for water or any other sign of contamination ,blew air thru it no contaminants, re-install fuel filter started the car it let it idle and it cut off after 4 minutes, let it sit for 15 min. it started again. the car have 55,000 miles ,no check engine light it idles normal and it has't quit while driving "yet"
any help will be appreciated thank you

Reply With Quote
  #2  
Old 06-25-2005, 09:13 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
If I were guessing, I'd guess crank sensor.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 06-25-2005, 09:23 PM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
99 sl

That is one I didn't think of, should it show a DTC code for that? I don't even know were that is in the engine, now I'm really worried. Where do I go from here
Reply With Quote
  #4  
Old 06-25-2005, 10:11 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
It won't set a code. But verify your fuel pressure first, a bad pump won't set a code either.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #5  
Old 06-26-2005, 01:00 PM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
99 sl

I will have to wait till the fuel filter I've order from Fastlane gets here, If I knew it will make it I'll just drive to Gainsville and let you take a look at it.
Reply With Quote
  #6  
Old 07-10-2005, 10:59 AM
"99 SL500
 
Join Date: Oct 2004
Location: Jacksonville Fla.
Posts: 332
99 sl

Good guess
replace crank sensor US $71.00, 10 minutes time, no more problems
thank you Steve

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300e hard warm start and stalling as rpms drop to idle MikeNJ Tech Help 1 06-13-2005 03:00 PM
91 300E - 103 warm start Rick Hall Tech Help 5 10-14-2004 01:35 PM
190E 2.6 - rough idle when cold + hard start when warm + ABS light on johnqle Tech Help 3 02-05-2004 09:48 PM
hard start and rough warm up on '72 280 se goodworkmax Tech Help 0 10-28-2003 07:32 PM
190E 2.3 - warm start problem Glen Tech Help 14 03-11-2003 12:46 PM



All times are GMT -4. The time now is 08:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page