Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-2005, 06:00 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,574
Question Testing A/C Compressor Clutch Control - MAS Unit ?

Good thing I got the A/C working on my back-up Honda last night 'cuz the '91 300-SELs A/C decided to go on vacation running an errand awhile ago. Worked on the way to where I was going(blowing cold air), but was dead after restarting about a min. later. No clutch engagement.

I know I have many things to test, but wanted to confirm something. I'm looking at a layout of the "Compressor Clutch Control" - 1990 300SE/300 SEL - page 304/3 in the ACC climate section - 126 car.

It looks like I can jumper 30 and 87 in the MAS to test the A/C compressor clutch control.

Am I reading this correctly?

Thanks for your time.

__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"

Last edited by Mike Murrell; 07-07-2005 at 12:42 PM.
Reply With Quote
  #2  
Old 07-06-2005, 06:35 PM
LarryBible
Guest
 
Posts: n/a
I'm not intimately familiar with your chassis, but there are two things that I would suspect in your case.

First is the ignition switch. After starting the engine only to have the a/c system not come on, wiggle the ignition switch. If you can make it come on this way, the problem is the switch.

Secondly, inspect the belt and its tension. If the belt slips a rotation sensor sends a signal that drops out the system. It may come on after starting again if it has had enough time to bleed off some high side pressure, decreasing the load thus allowing it to start without making the belt slip.

The other more obscure problem could be a bad clutch or locked up compressor. With engine not running reach down and turn the forward most part of the compressor to ensure that it turns smoothly. If it does, jump 12 volts directly to the clutch with engine off and listen for the clutch to click. If it does not, then the clutch coil is open or the air gap is too wide.

Good luck,
Reply With Quote
  #3  
Old 07-06-2005, 07:38 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,574
Larry:

Thanks for the advise.

Steve Brotherton confirmed what I believed I was seeing in the MB schematic in an older post below.

190e 2.6 A/C
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #4  
Old 07-07-2005, 05:58 AM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,574
Larry nailed it with his first suspect -> ignition switch.

I first checked fuses and belt tension; all looked ok.

Car was then started and an attempt to activate the a/c from the push button controller(PBC) was made. The compressor clutch did not engage.

I then jiggled the key in the ignition with the car running and the a/c activated.

Time for a new ignition switch. Hope there's an elect. piece that can be replaced w/o requiring a new key as well.

Thank you Larry.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #6  
Old 07-07-2005, 12:29 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,574
Arthur:

That's good news. Thanks for your response.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #7  
Old 07-07-2005, 01:15 PM
Registered User
 
Join Date: Dec 2000
Location: AL
Posts: 1,219
Wow! Great call.

I never would have suspected the ignition switch.

__________________
2012 E350
2006 Callaway SC560
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 16v euro climate control & A/C questions kiato4 Tech Help 5 04-25-2005 07:52 PM
450SL Cruise Control 450sl4me Mercedes-Benz SL Discussion Forum 4 04-16-2005 02:01 AM
ME Control unit, please help. spinedoc Tech Help 6 05-29-2004 09:48 AM
S500 Climate control unit bigintruder Tech Help 6 06-02-2003 10:05 PM
w140 A/C Pushbutton Unit Removal sail42 Tech Help 2 10-31-2001 10:27 PM



All times are GMT -4. The time now is 10:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page