Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-2005, 09:33 AM
bhatt's Avatar
Registered User
 
Join Date: Apr 2000
Location: Oakville, Ontario, Canada
Posts: 421
300SL hesitation when accelerating

Hello all,

I have recently purchased a 300SL (1990) and am having a problem with it. It hesitates upon accelerating away from a stop sign or traffic light. Car idles and runs fine otherwise, but just feels like it's going to stall when initially accelerating.

If I run the A/C it is worse.. probably because of the compressor load.

Car was driven only 6000 miles in the last four years before I bought it. Didn't pass the emission test (high HC) so my tech did the following:

-New cap, rotor, spark plugs
-Fuel injector flush
-Replaced air filter

Before I took the car to him, it actually stalled a few times. It had 5 gal of what I can assume was "old" gas (I know it was at LEAST one year old according to the previous owner). I added 15gal of fresh premium gas before dropping it off at the shop.

Questions:
-Is it the mix of 75% new/25% old gas that is causing the hesitation and will it be fixed two tanks from now?
-Should I put a new fuel filter on the car as a "guess" at the problem? My understanding is that the current filter is at least 5 years old.
-Assuming the tanks of fresh fuel & new filter doesn't fix it, what else could be wrong? I don't want to go changing parts (I could buy new ignition wires, for example) without knowing where to look next! I'd like to chase after the next "most likely" cause before I start changing expensive parts.

By the way, the tech was told to replace whatever necessary in the tuneup. I think we can assume that ignition wires are not the problem, as he would have called me to OK new wires if that was the case.

Thanks!
Neal

__________________
'83 300SD 335,000km (207k) mi SOLD
'87 560SL 163,000km (101k mi) SOLD
'86 300SDL 356,000km (220k mi) SOLD
'92 500SEL 250,000km (155k mi) SOLD
'90 300SL 140,000km (87k mi) SOLD
'01 S430 260,000km (161k mi) SOLD
'03 SL500 167,000km (104k mi) SOLD
'07 S550 4MATIC 235,000km (146k mi) SOLD
'07 GL320 CDI 4MATIC 348,000km (215k mi)
'13 GL350 BlueTec 4MATIC 155,000km (96k mi)
'14 SL550 92,000km (43k mi)
Reply With Quote
  #2  
Old 07-27-2005, 03:17 PM
Registered User
 
Join Date: Sep 2003
Location: Dallas, Tx
Posts: 701
I would change the filter next, those are inexpensive and can usually cause hesitation. If it is 5 years old that is a good guess. As far as the plug wires, do a visual inspection, als the plugs are cheap, so I would replace those next, you can get an idea of the condition of your engine by inspecting the old plugs when you remove them. Give those a try, if they have not been replaced as of yet it is a good idea to do it as part of maintenance. Keep in mind when you buy an SL it will take awhile to get the car up to your standards, and into a regular maintenance regimen. It took me a year to get my car just right, so be patient, those cars have the fuel distributor on them, so don't let it sit around, it is not good for it.
Good luck!
Brian
__________________
Brian W. Heitman

www.MBCA.org/northtexas

Join MBCA!!!
Reply With Quote
  #3  
Old 07-27-2005, 03:26 PM
Registered User
 
Join Date: Sep 2003
Location: Dallas, Tx
Posts: 701
oops, I see you replaced your plugs already, did your mechanic comment on the condition? Replace the fuel filter, inspect the wires, run a few tanks of gas, see how it does. Check for vacuum leaks, and that your throttle control linkage is well lubricated. Good luck!
Brian
__________________
Brian W. Heitman

www.MBCA.org/northtexas

Join MBCA!!!
Reply With Quote
  #4  
Old 07-27-2005, 04:02 PM
bhatt's Avatar
Registered User
 
Join Date: Apr 2000
Location: Oakville, Ontario, Canada
Posts: 421
Brian,

Yes, the plugs were definately changed. No comment from the tech on how they looked (I'm sure they've been disposed of) but he didn't mention anything out of the ordinary. Car failed emissions badly but passed with flying colors after all of the changes (oil, spark plugs, air filter, etc.).

Will try the fuel filter today or tomorrow and see how it goes.. keeping my fingers crossed!

Thanks for your help!
Neal
__________________
'83 300SD 335,000km (207k) mi SOLD
'87 560SL 163,000km (101k mi) SOLD
'86 300SDL 356,000km (220k mi) SOLD
'92 500SEL 250,000km (155k mi) SOLD
'90 300SL 140,000km (87k mi) SOLD
'01 S430 260,000km (161k mi) SOLD
'03 SL500 167,000km (104k mi) SOLD
'07 S550 4MATIC 235,000km (146k mi) SOLD
'07 GL320 CDI 4MATIC 348,000km (215k mi)
'13 GL350 BlueTec 4MATIC 155,000km (96k mi)
'14 SL550 92,000km (43k mi)
Reply With Quote
  #5  
Old 07-28-2005, 08:54 AM
bhatt's Avatar
Registered User
 
Join Date: Apr 2000
Location: Oakville, Ontario, Canada
Posts: 421
Update

Haven't had a chance to swap the fuel filter (will do so tomorrow AM) but I did the following last night:

-Put a small bottle of "STP Water Remover" in the gas tank. Says it treats up to 20gal and I had about 15gal in the tank at the time.
-Drove the car hard in 2nd gear for about 2 miles. Started driving the car a little harder than I have been (I've been babying it for the first few days since I bought it).

Now the "hestitation" is getting a little better. There's light at the end of the tunnel! The hesitation is shorter, and once or twice I could swear it didn't happen at all..

Willl continue driving the car a bit hard until I burn up the remaining 3/4 tank of gas. Will fill it with fresh fuel, change the filter and let you guys know how it turned out.

THANKS FOR ALL THE HELP, ESPECIALLY BRIAN!

Neal

__________________
'83 300SD 335,000km (207k) mi SOLD
'87 560SL 163,000km (101k mi) SOLD
'86 300SDL 356,000km (220k mi) SOLD
'92 500SEL 250,000km (155k mi) SOLD
'90 300SL 140,000km (87k mi) SOLD
'01 S430 260,000km (161k mi) SOLD
'03 SL500 167,000km (104k mi) SOLD
'07 S550 4MATIC 235,000km (146k mi) SOLD
'07 GL320 CDI 4MATIC 348,000km (215k mi)
'13 GL350 BlueTec 4MATIC 155,000km (96k mi)
'14 SL550 92,000km (43k mi)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitation 91 300SL pmckechnie Tech Help 4 08-22-2004 11:29 PM
300SL Gullwing Celebrates 50th Anniversery GermanStar Vintage Mercedes Forum 12 04-09-2004 10:51 PM
Hesitation in accelerating from stop vadrill Tech Help 12 06-17-2001 03:36 PM
W126, 300se hesitation when accelerating ben Tech Help 1 09-07-2000 05:45 PM
83 300SL Vibration when accelerating NicolasF Tech Help 1 04-03-1999 10:13 PM



All times are GMT -4. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page