Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-28-2001, 01:34 PM
Posts: n/a
i currently own a UK registered 1997 SL320 fitted with a hard top, the red roof switch on the centre console is permanently lit, there is no sign of any activity from the roof motors when the switch is flicked forward to release the hard top and put up the soft top. i have checked the wiring harness to the fuse box and i have power at the fuse box. i'm not sure where to look for the roof control unit, i have tried under the front seats, located there are two ECU type units, one under each seat, which i understand is the seat control units.(is the roof unit connected to these? the power seats are not working either.. possible damp under seats????)
also under the rear seats are two ECU's, the one is for the transponder/immobiliser unit, but what is the other one for???
any help on the above problem would be greatly appreciated, if any one has the wiring diagrams for the roof system could they mail me details??

richy(UK Wales)
Reply With Quote
Old 01-28-2001, 09:06 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The controllers under the seats are for the seats only. The softtop/rollbar unit is behind the rear panels.

I would start by checking the fuses in the rear of the car and checking all fuses for cracks. Small cracks will cause things to be inoperational as will low system voltage.

Donnie Drummonds
Reply With Quote
Old 01-29-2001, 02:40 PM
MBenzNL's Avatar
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417

I had the same problem with my 1990 300SL. I couldn't close the opened soft top anymore and the car only fastened the hard top partly. The back of the hard top was fastened as should, but the front fixings were just not tight enough (I could hardly see any difference with the normally "closed" hard top, but the hard top did just not fit the fixings until the end).
As long as the hard or soft top is not entirely closed, the switch will stay illuminated.
I had to bring my car to the MB dealer to get a new hydraulic valve and all was well again...

If you try to release the hard top, you should try it whilst the ignition key is turned on and the engine is not running. Flick the switch backwards (not forwards) and hold it there for a longer time to give the system some time to get some oil pressure...(it helped me getting off the not tightened hard top).

1990 300SL-24
1993 C250D
with a minor 600+k kilometer
(the Netherlands)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
skyview roof problem ephrem abate ML, GL, G-Wagen, R-Class, Unimog, Sprinter 1 08-26-2004 07:05 PM
Power antenna problem mbdad Car Audio and Multimedia 9 07-14-2003 12:25 AM
Power Seats? 2.6L Tech Help 0 11-28-2002 12:40 AM
power seats & power mirrors work only with doors open jackw Tech Help 0 11-14-2002 11:44 PM
Power steering problem: 2.3-16V Mahesh Patel Tech Help 3 08-27-1999 11:05 PM

All times are GMT -4. The time now is 07:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page