Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-18-2001, 06:25 PM
Registered User
 
Join Date: Feb 2001
Location: Northumberland, UK
Posts: 1,294
I have a 98 C200 which was showing the coolant warning lamp constantly. It needed a new instrument cluster as correctly identified by the techs on this forum and my dealership.

However, the dealer had to get the part on back order from Germany. After a week or so, I get a call, my car is ready. When I pick it up, the locks don't work and it doesn't start: flat battery. I assume someone left the courtesy light on or a door ajar but as I drive home I notice that the warning lamp is still on. When I park up and shut off the engine, the cooling fan starts up. That's the cause of my flat battery!

To be fair, the dealer was excellent at this stage: at 6pm on a Saturday they send a flat 60 miles to collect my car and drop off an A-Class (a very good car, btw). But it should never have happened. They fix the problem this time, but it takes another three days. Turns out they put the old instrument cluster back in the car first time round and sent the new one back to Germany for examination!!

But then today (four days and 750 miles later), I washed the car. I popped the bonnet to wipe down the engine bay: what is lying on the top of the motor but a ten inch ratchet spanner extension!

Is this usual MB service? What's the best way to handle this? I was very happy with the deal I got on the car from this dealer and am loathe to go elsewhere.
Reply With Quote
  #2  
Old 02-18-2001, 09:49 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Call and speak directly to the Service Manager and tell your story.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Typical cost and what is done at a 60k service. spinedoc SL Forum 18 07-14-2004 09:22 AM
240D owners, if you have your owners manual handy... acastell Diesel Discussion 13 02-28-2004 09:52 PM
Attention Canadian Flexible Service Vehicle Owners! need2speed Off-Topic Discussion 5 11-27-2002 09:10 PM
Is it necessary to get 15k service? AMGCKlass Tech Help 5 04-01-2000 10:27 PM



All times are GMT -4. The time now is 01:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page