Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-31-2001, 02:23 PM
Paul L. Coffey
Posts: n/a
I have an '84 Euro 500SEC with 205,000 miles on it. Car runs great! Except, I my valve train rattles when the car is warmed up. When I first start the car in the morning, everything is quiet and the oil gauge pegs out. As it get warm, the oil pressure drops to about 1.5 to 2, which I believe is normal (maybe a little on the low side) and the rockers are rattling common to the #1,2,3,6,7 position (at least that's what it sounds like). I have not confirmed this with the car warm by removing the valve covers and either starting it (messy) or checking to see if the ball studs have sank. I have replaced all the lifters (ball studs) and did not re-shim any of the rockers. I had checked the new ball studs with a go/no-go gauge and they all seemed fine. My suspicion is: I am not getting enough oil pressure to the top end when the car is warm, due to the clearances opening up c/t the lower end. Or the oil pump is just plain wore out. What I'm wanting to know is: am I on the right track? or do I need to do something else? I'm on an economy budget here and would like to fix this potential problem before it gets any worse. Summer is coming and it is hot here. Oil pressure will drop to about 1.2 as it did last year. Save my SEC. Thanks, Paul
Reply With Quote
Old 09-27-2001, 02:13 AM
Registered User
Join Date: May 2001
Posts: 301
Any thoughts? My 420 is also doing this.
Reply With Quote
Old 09-27-2001, 12:12 PM
Registered User
Join Date: Jun 2000
Location: Tucson, Arizona, USA
Posts: 180
I won't pretend to be the expert on this particular issue, but try the forum at -- there are a lot of engine experts there and a searchable archive. Cheers, Andrew Seidel.
86 560SEC
85 500SEC Lorinser
83 300D Turbo
75 240D
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rattle, rattle 95% fixed..... Bruce B Tech Help 0 01-18-2004 01:09 PM
need help 617 rattle rattle rattle (loose alternator) rattle rattle coachgeo Diesel Discussion 9 08-11-2003 09:37 PM
Hard Cold Start Slight Miss in Idle When Warm (500sec) Scott500SEC Tech Help 1 12-15-2002 06:37 PM
weird 126 front end rattle Joseph Bauers Tech Help 7 02-13-2002 06:52 PM
1989 w124 260E rattle atombaum Tech Help 2 09-21-2001 01:03 PM

All times are GMT -4. The time now is 09:43 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page