Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-13-2006, 03:51 PM
Registered User
 
Join Date: Oct 2002
Posts: 178
How to read engine code for 190E

1990 190E 2.6 with CHECK ENGINE light on, which came on after car shut down after driving, perhaps due to losing electrical power.

Car seems to drive fine, idle normally (as before), no puttering sounds. By the battery is that black box with a LED light and numbers next to holes. I have never read codes before and this is a bit intimidating. My search shows that I should press the button and hold for 3-4 seconds. The rest makes no sense to me as far as number of blinks the LED makes. Could someone tell me how I can read the code and cancel the CEL in layman's terms? Thanks.

Reply With Quote
  #2  
Old 08-14-2006, 12:26 AM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 233
Hi,
Please turn on the ignition (but DO NOT START the car). Press that little but in that diagostic socket box near the battery. Hold it between 3-4 seconds and release the button. Count the number of times the red light on the socket box blinks. If it blinks twice it equals code#2, thrice equlas code#3 etc. Now, to reset the CEL, after you count the blinks, hold down the button again for about 8-10 seconds and the red light near the socket blinks once - meaning it reset the CEL.

After you are thru with the above process, start the engine, the CEL should be gone. However, if the problem is chronic the CEL will come on within 2 minutes after you start the car. Sorry , I do not have codes for 190e 2.6. I do have codes for 190e 2.3 4cyl. If you search this site for '190e 2.6 codes' you should be able to find it. Hope this helps.

smk_texas
98 s420
93 190e 2.3
Reply With Quote
  #3  
Old 08-14-2006, 12:41 AM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 233
Hi,
I have codes for 93 190e 2.3 4cyl 201- chassis , engine 102.985. I'll post it tomorrow. It is at work.
smk_texas
Reply With Quote
  #4  
Old 08-14-2006, 04:52 PM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 233
Hi,
Here are the code descriptions for a 201 - 93 190e 2.3 4cyl. Hope this helps

1 No fault found
2 Throttle position switch - wide open throttle fault
3 Engine coolant temperature sensor
4 Air flow sensor position indicator
5 Oxygen sensor
6 Not used
7 TD-signal (rpm)
8 Altitude correction capsule
9 Electronic hydraulic actuator (EHA)
10 Throttle position switch - closed throttle position fault (idle)
12 Exhaust gas recirculation temperature sensor


smk_texas
Reply With Quote
  #5  
Old 08-14-2006, 10:52 PM
Registered User
 
Join Date: Oct 2002
Posts: 178
Thanks, texas! I just got back from reading the code. First time nothing, but it turned out I only had the key in the ON position (no idiot lights on). Second time around I put key in the second spot (all idiot lights on) and the LED blinked. First code is #7 and second code is...#17! What the-- I don't think I properly erased the first code after I read it because when I held the button down for 6-9 minutes, no light came on afterwards. I was able to clear both codes (assuming that I did read two codes). Is #7 code a serious problem? Thanks so much!

edit to add: Started the car and let it idle for over two minutes. The CEL did not come back on. Does this mean I'm out of the woods? Thanks.

Last edited by frosty; 08-14-2006 at 11:21 PM.
Reply With Quote
  #6  
Old 08-15-2006, 01:45 PM
Registered User
 
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 233
Hi,

Looks like you did well reading the codes. Now, I do not know what code #7 & #17 translate to. Your engine # is 103.942. The codes I posted are for engine 102.985. Please do a search in this forum for '103 codes' and see what you find. As far as the CE light not coming on, it could be temporary. Sometimes it takes a while before it comes back on.

smk_texas
98 s420
93 190e

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page