Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-12-2001, 01:39 PM
Posts: n/a
I have a 1987 190E that I have had for about 6 months. It has 140k miles and was previously own by a gentleman in his 80's who was apparantly very neglectful. It smokes and my tech says it needs rings, but no need to be in a rush to get the job done. I've replaced the tires with factory sized Pirrelli 4000t's, a new starter (the old one was drawing too much current and taxing the battery), and replaced a leaky radiator. Also, the serpentine belt was too wide and made a lot of noise. I have a new tensioner for that belt as I discovered that the bearing on the current one makes the car sound like a diesel!

My issue du jour is that my car starts beautifully when cold, but after a short warmup period, I have to depress the accelerator ro the floor to get it to fire. Doing so, it starts after just a few turns, surges a bit and the seems to run fine. Occasionally, it behaves as if it is going to die while idling.

BTW: WHile I don't contribute often, I read this board every day, sometimes seeral times a day. THanks for the great site to visit.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190E headlight for sale like new 2.3 2.6 2.3 16v euroamg Mercedes Used Parts For Sale & Wanted 4 02-22-2005 06:27 PM
Odd 240D behavior... acastell Diesel Discussion 25 06-14-2004 01:39 PM
1992 500SEL Transmission Odd Behavior TexasStarMan1 Tech Help 4 12-21-2003 08:32 PM
Wierd impulse light behavior on '91 190e 2.3 irieite Tech Help 0 03-15-2003 07:33 PM
2.3 8V air flow sensor work in a 16v daveCT Tech Help 1 02-19-2003 10:57 AM

All times are GMT -4. The time now is 04:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page