Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-19-2001, 12:58 AM
Posts: n/a
Hello Everyone....
I've had my euro headlights for my 89 300E for about 3 months now and i have not had any problems with them. But last week i noticed that my right headlight was blown..after further inspection i found out it was not was just really dimmed and barely visible. I have 90/100w H4 HID bulbs and i thought that the cause of the problem might be that my wiring system couldn't handle the load so i went ahead and went back to the regular H4 60/55W halogen bulbs and the result was the same..dimmed..i tried both bulbs on the drivers side headlight and both worked fine... can someone help me on where to go from here...could it be my headlamp itself or a bad wire ???Any help would be appreciated.

Thank You
Reply With Quote
Old 04-19-2001, 06:38 AM
Registered User
Join Date: Aug 2000
Posts: 269
On all three of my MBs the right and left head light are fused seperately. Check your fuses for corrosion. If you haven't done so replace all the fuses and clean the contact points with something like deoxit. These fuses fatigue over time and you can't always tell by looking. For $5 to $10 Put in new ones you'll be amazed at how many germlins this will exorcise

Bob D.
Reply With Quote
Old 04-19-2001, 05:36 PM
MBenzNL's Avatar
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
Is the dim problem only low beam related, or does the problem occur with high beam (same bulb, same connector) as well? If so, it might be a ground problem...

1990 300SL-24
1993 C250D
with a minor 600+k kilometer
(the Netherlands)
Reply With Quote
Old 04-20-2001, 12:06 AM
Posts: n/a
The problem is with both low and high beam. Today i went ahead and checked the inside of the headlight and as i moved the H4 connector around the light came on..i thought the overwatt bulb might have melted the connector but everything seems of right now everything is working fine..there might be something loose...i will check again.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS 126 Parts: New Euro Headlight Parts, Bumper Chrome cam69ss Mercedes Used Parts For Sale & Wanted 0 01-07-2005 03:44 PM
Euro Light Wiring for '80 240D tradonguy Diesel Discussion 9 04-27-2004 06:27 PM
96 C280 Wiring Harness Problem? Martineau Gauda Tech Help 1 06-22-2002 09:12 PM
New Bosch Euro Headlight LENSES For Sale ebennz Mercedes Used Parts For Sale & Wanted 2 06-21-2002 12:01 PM
Euro Headlight Wiper Blade Part Number steif1 Diesel Discussion 0 05-23-2002 08:50 PM

All times are GMT -4. The time now is 08:41 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page