Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-22-2001, 10:30 PM
bladesmith
Guest
 
Posts: n/a
Out of the blue two days ago I cranked on my ever dependable 420 SEL and the idle immediately raced and wouldn't stop racing. The yellow ABS warning light also came on and stayed on. If you wait long enough (two minutes or so) it will finally slow down to normal---or put it in gear and it wll return to normal idle, but only after burning rubber and jerking the trans big time when it engages at that high speed. It does it every time, whether warmed up or cold. Sounds like computer stuff or electronics at the least which leaves me out in the home repair department. Any suggestions would be much appreciated. Bear in mind that I live far from a MB dealer. Thanks in advance,
Rob Hudson
Reply With Quote
  #2  
Old 04-23-2001, 01:11 AM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935
It's your OVP


Change your overvoltage protection relay. That's the cause.
__________________
Regards,
Aaron
Reply With Quote
  #3  
Old 04-23-2001, 11:30 PM
bladesmith
Guest
 
Posts: n/a
Thanks very much Aaron---I made an appointment with an independent MB mechanic to do what you suggested. He said he agreed with your diagnosis completely. We'll find out Wednesday. This forum is truly a great thing. I wonder how MB owners managed without this and the net in the stone age.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
C220 stumbling idle when starting tryfunke Tech Help 3 09-09-2012 03:28 PM
No fast idle Berolina Tech Help 0 05-28-2002 08:13 PM
intermittent fast idle getting worse Marc Tech Help 11 05-12-2002 03:36 PM
No fast idle on cold start 380SL JRJ Tech Help 0 02-16-2002 10:27 PM
Fast Idle Antilock light on jcciem Tech Help 3 09-04-2001 09:18 AM



All times are GMT -4. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page