Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-16-2002, 09:27 PM
JRJ JRJ is offline
Registered User
Join Date: Jun 1999
Location: Spring Hill, FL USA
Posts: 39
No fast idle on cold start 380SL

Advice needed for 82-380SL euro. Recent difficult starts with no high idle. Engine runs 550 to 850 rpm cold in park with some stumbling and surging. In gear idle drops to 550 and is fine when warmed up. No loss of power or acceleration noted. At cold and warm idle speed there is white smoke that dissappears with acceleration. There is a slight dip in rpm with light accelerator pressure and a occasional skip.

So far I have replaced the warm up regulator, distributor cap and rotor, checked all plug wires for proper resistance, recently replaced alternator also. Following my Chiltons the idle speed control valve plug reads battery voltage with the key on and an audible click is heard. With the engine running warm the same plug reads 11.2 volts not the 4-6 volts the manual specifies. Unplugging the valve and the idle jumps to 1500. The electrical plug to the warm up regulator reads 12.2 volts with the engine running. The electrical plug to the cold start valve reads 0 volts with key on or engine running. I do not feel any vibration from the cold start valve or frequency valve. I suspect the control module is the primary problem. Any tips on the proper testing and diagnosis procedures?

Does anyone have a vacuum line diagram for a euro 380SL? My US spec manual does not correlate with my car and I suspect some of the vacuum lines have been misrouted also.

All advice and suggestions are greatly appreciated.
Car still drives fast and smooth when warmed up and delivers 20-22 mpg even with the above problems

82 380SL euro (sold)
93 400E (sold)
99 BMW 328IC (Wife)
2001 GMC Yukon XL
2001 Honda Accord (son #1)
2005 Mazda 6 (son #2)
2006 Honda civic (daughter)
"Always too many cars in the driveway"
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
380SL Stalls At Stoplight & Cold Start Problems? ezrider SL Forum 1 02-23-2004 08:26 AM
Idle problem on cold start jlomon Tech Help 0 10-18-2003 10:40 PM
Rough idle after cold starting difficulty - related? Fintail Fan Tech Help 8 02-19-2003 10:38 AM
Easy cold start, but stahling idle - '85 300TDT Peyton300TD Diesel Discussion 1 11-29-2002 01:01 AM
92 400E fast idle - where to start ? RM92400E Tech Help 19 02-20-2002 02:36 AM

All times are GMT -4. The time now is 08:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page