Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-13-2001, 07:59 PM
Registered User
 
Join Date: Oct 2000
Location: Nashville, TN USA
Posts: 16
I have a 1986 420 SEL, and am having some problems.

I had the a/c compressor replaced with an MB reman unit approx. 2wks ago.

My problem is this: the fuel, oil pressure, and temp gagues intermittently "die". There is no rhyme or reason as to under what conditions this occurs. All other instrument panel functions work OK. When this happens, the a/c compressor also kicks off, and no more cool air. These are the only systems that are affected by this.

When this first happened about a week and a half ago, I replaced the fuse for good measure and cleaned the contacts. (it is not blowing the fuse btw). The problem stopped. Yesterday, the gagues died and no a/c compressor.

Is there a relay somewhere that I need to check before breaking out my multimeter? I have looked in my electrical troubleshooting manual, and it only shows the fuse and sending units in the circuit.

I think that if it were the left bank of gagues, there would be other problems with the instrument cluster, as the wiring harness plugs into the back of these

This never happened before replacing the a/c compressor, so I that leads me to think that the problem is with the a/c compressor or some related relay.

Any help appreciated, thanks.
__________________
2000 ML430 86k
2000 C280 Sportline 100k
'86 420 SEL 178k
'91 Audi 100 179k
'88 BMW 750il 167k
'83 300 SD 167k (sold)
'79 300 D 78k (sold)
Reply With Quote
  #2  
Old 05-13-2001, 10:05 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Replace ALL fuses! All fuses have to be replaced! Did I mention ALL of the fuses?

__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 05-14-2001, 10:28 PM
Registered User
 
Join Date: Oct 2000
Location: Nashville, TN USA
Posts: 16
Thanks for the tip Benzmac- once again this forum has saved my sanity.

Went to the dealer and purchased all new fuses, replaced the existing ones and my problem disappeared.

What gives? Is this common? All of the fuses I removed were in good condition- none were blown. Just curious.



__________________
2000 ML430 86k
2000 C280 Sportline 100k
'86 420 SEL 178k
'91 Audi 100 179k
'88 BMW 750il 167k
'83 300 SD 167k (sold)
'79 300 D 78k (sold)
Reply With Quote
  #4  
Old 05-15-2001, 07:34 AM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 11,777
I saw the same thing with my E320

recently had a situation where the aux fans were not coming on like they should. I replaced the appropriate fuse and have not had anymore problem.
Jim
'85 300D
'95 E320
'97 CRV
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
oil pressure gauge gone goofy, 420 SEL William Tech Help 5 08-28-2004 01:48 AM
gauge problems after removing cluster schumi Tech Help 4 08-07-2004 09:41 PM
photos of gauge cluster boost gauge, part 1 sixto Diesel Discussion 2 03-20-2004 01:44 AM
300 SEL problems problems. Crap!!!! tosbt Vintage Mercedes 25 10-09-2003 04:34 AM
Rough idle @ economy guage not working 420 SEL bermuda Tech Help 3 01-09-2002 05:09 PM



All times are GMT -4. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page