Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-28-2001, 05:02 PM
Posts: n/a

I've got this weird thing happening to my car. It only happened twice, but it's very odd.
When I use my brakes to slow down, I suddenly notice that the power steering is gone and I have to use force to steer. And when I stop, the engine is dead! I have to use the key to start again. The car is in good shape and runs completely in order, except for this freak thing?
I'm not really sure if the braking of the car has anything to do with it, but both times it occurred, I was braking firmly, but not that hard. The first time it happened, I figured I must have gone too slow without shifting down properly, and the engine stopped from excessive load being put on it, but today it happened in a downhill slope, and I know I had the clutch to the floor while braking. And suddenly "-What the F*!?" ,and it's dead! Any ideas?


Reply With Quote
Old 05-28-2001, 05:52 PM
Q Q is offline
Registered User
Join Date: Aug 2000
Posts: 839
Check your battery cables. I had this happen once in a Honda Accord. The ground wire that connected to the engine block was being held together by the insulation. When I braked, the wire disconnected and the car died. Check both ends of the wires, not just the connections at the battery.
Reply With Quote
Old 05-28-2001, 07:40 PM
Posts: n/a
OK, I'll make sure the connections are OK.
Thanks for the tip, I'll get back when done...

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 10:53 AM
300SE Engine does not idle and dies Dipil Tech Help 2 01-27-2005 06:42 AM
tickover slows imperceptibly till the engine dies w123jab Tech Help 0 05-16-2004 08:09 AM
Brake & Turn Steering and Engine dies M103 BlackBeauty Tech Help 0 04-07-2003 09:59 PM
When decelerating engine dies, please help? 88_Benz_CE Tech Help 0 03-11-2002 10:03 PM

All times are GMT -4. The time now is 05:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page