Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-03-2001, 08:55 PM
Registered User
 
Join Date: Nov 2000
Posts: 168
I think I'm having some sort of vacume problem. Last night I noticed that when I unlocked my driver side door, the passenger side did not unlock also. When I locked the driver side door, the passenger side door locked. Today, the passenger side door would not unlock or lock by using the driver side. I also can't get into my trunk! I don't have a key for the trunk. I never needed one because the driver side lock would unlock the trunk. Where do I start? Shouldn't there be some sort of central locking device? Where is it on my car?(1980 300 CD) I looked for any disconected vacume lines under the hood, but could not find any. I really need help. Thanks, andy
Reply With Quote
  #2  
Old 06-03-2001, 09:32 PM
Johnson Chan
Guest
 
Posts: n/a
Andy,

I am going through the same problem as you right now. I have my door skins off and in the process of fixing the 84 300D turbo.

What you need to do is take apart the door skins and look in there, when I took mine apart, I found this plastic white peice broken, so I needed to buy a new $1 peice of plastic right? WRONG, the dealer only sells the entire lock assembly for $120.00, so i ordered it and replaced it, but the door lock still didnt work like its supposed to, why? Because another metal spring was broken, Its hidden behind the door so you have to remove it to check it, so I got to order that from the dealer monday.

It could be a vaccum problem or a broken spring, or a broken peice of plastic, the only way to find out for sure is take the skin apart.

As far as the trunk, I replaced the vacumm peice but i still cant lock or unlock it with a key, so I need to get it fixed next.
Reply With Quote
  #3  
Old 06-03-2001, 11:19 PM
Registered User
 
Join Date: Nov 2000
Posts: 168
Johnson, Thanks for responding. It's little things like this that end up causing the most frustration. What gets me is that it worked fine just a day ago. I guess it's just our turn. From what I've read and heard EVERYONE will have some sort of vacume problem sometime. I did notice a "loose springy" sound coming from befind the door panel when I unlocked it by hand. I'll tear it apart soon and see what I can find. Please keep me posted as to your progress. Thanks, andy
Reply With Quote
  #4  
Old 06-04-2001, 12:04 PM
Icesailor
Guest
 
Posts: n/a
Andy,

If you look at the thread "82 300TD A/C problem" you may find some information I posted that might assist you in your lock diagnosis. I hope it helps.

Rick
Reply With Quote
  #5  
Old 06-04-2001, 10:39 PM
Registered User
 
Join Date: Nov 2000
Posts: 168
Thanks Moraine, I just got home and am about to go do some more "fixin". Here's what I know so far. 1. Driver side door has no effect on other door or trunk. 2. It also doesn't seem to have the resistance it once had when unlocking with the key. 3. Passenger side seat does lock when doors are closed and engine is running. 4. Driver side does not lock. (although I can hear a release of pressure when I push release button) 5. Trunk does not release at all. 6. Fuel door is stuck in unlocked position. 7. It's a good thing I took all of my tools out of my trunk a few days ago. I'm going to go take off the driver side panel to start with. Thanks for your help. I hope you can help me figure this out. andy
Reply With Quote
  #6  
Old 06-05-2001, 01:54 AM
Registered User
 
Join Date: Nov 2000
Posts: 168
UPDATE. After a few hours of detective work I have some good and bad news. By plugging different lines I got to the point where my trunk unlocked. With the car running and driver side window down I could do the following. Unlock the driver side door(from outside reaching in through window), the passenger side would unlock anywhere between 1 and 5 seconds. The trunk would also unlock after about 20 senconds. Passenger side seat would lock and unlock. Driver seat would take much longer to lock. I snooped around the trunk lock area and heard a leak. The blue vacume device that allows the trunk to unlock has a black rubber seal that was ruptured. I took it out and will try to find a replacement. I plugged the lines that connected to it. I noticed that the vacume valve in the driver side door leaked also. Maybe just worn. I took that out also. Does this sound familiar to anyone? I'm I on the right track? How much do these things cost? Moraine, what do you think? thanks for any help. Please forgive my inability to make a long story short. andy
Reply With Quote
  #7  
Old 06-05-2001, 02:10 AM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
It sounds like you wouold be doing it right.

Track down the leaks and repair them. The parts probably don't cost much, see if you can find the part numbers or go through the fastlane...

Alon
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #8  
Old 06-05-2001, 03:32 PM
Registered User
 
Join Date: Nov 2000
Posts: 168
Moraine, Thanks for the words of encouragement. I will replace the trunk and door element as soon as possible. If that fixes the problem I will be happy. If not I'll keep trying. Even if it does fix it, I'll start replacing pieces on a regular basis. After a short while, They'll all be new. I let you know what happens. Thanks for your help. I just love the 300 coupe! andy
Reply With Quote
  #9  
Old 06-13-2001, 01:33 AM
Registered User
 
Join Date: Nov 2000
Posts: 168
FIXED!!! I ordered my parts from fastlane and they were fast. The package came to my house at 10am on friday. But, I wasn't home until 11am. I had to wait until monday. Too much traffic. This morning I picked up my stuff(master diaphram and trunk diaphram) from UPS and I installed them in the parking lot in about 5 minutes. It works fine now. Thanks for helping Moraine and others. andy
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300CD trunk won't open cmlcollins Tech Help 6 09-26-2004 03:20 PM
trunk locked can't open it !! pat q Tech Help 1 04-06-2004 01:17 AM
Trunk opening? SLeeper SL Forum 7 03-22-2004 04:28 PM
Trunk won't open Nigel Morris SL Forum 5 07-31-2002 03:50 AM
124 Trunk won't open gman1 Tech Help 2 08-30-2001 02:03 PM



All times are GMT -4. The time now is 07:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page