Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-04-2001, 07:47 PM
JL
Guest
 
Posts: n/a
The tach , gas & oil pressure gauges , & speedo went out this morning. The clock , & the vacuum & temperature gauges still work. Any ideas on where to start looking for a problem ? Thank you.

-John Lesko
Reply With Quote
  #2  
Old 06-04-2001, 11:46 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Internal cluster ground.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 06-05-2001, 12:57 AM
Petra
Guest
 
Posts: n/a
this happened to me a few weeks ago and it was only a blown fuse. i would try that. let me know what happens. thank you
Reply With Quote
  #4  
Old 06-06-2001, 10:25 AM
JL
Guest
 
Posts: n/a
Thanks for the reply Steve. Does an internal cluster ground entail the removal of the full panel that holds the gauge cluster for repair ?

-John Lesko
Reply With Quote
  #5  
Old 06-06-2001, 10:30 AM
JL
Guest
 
Posts: n/a
Thanks for the reply Petra.Where is the fuse located ? The owners manual was of no help in that regard. I also checked the fuse box under the hood ( no blown fuses )& the fuse chart on the fuse box lid.

-John Lesko
Reply With Quote
  #6  
Old 06-06-2001, 03:57 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Does your car have a fuse for the instrument cluster? I think that the 1995 C280 that Petra has is electronic, with electrical wires controlling them. Thus a blown fuse cutting out the electronics of the cluster. Yours seems like it would be cable-driven, though I could very well be wrong. Just a thought. But I'd still definitly check for a fuse because not only the speedo is out, but other gauges too.

[Edited by David C Klasse on 06-06-2001 at 04:55 PM]
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #7  
Old 06-06-2001, 04:53 PM
JL
Guest
 
Posts: n/a
Thanks for the reply David. I went back & checked for an auxiliary fuse box. I double checked the main box again & found fuse number 6 blown. It wasn't that noticeable earlier. It is now. I replaced it & all is now fine.

-John Lesko
Reply With Quote
  #8  
Old 06-06-2001, 05:02 PM
JL
Guest
 
Posts: n/a
Thanks for the tip Petra. It was fuse number 6.

-John Lesko
Reply With Quote
  #9  
Old 06-06-2001, 05:05 PM
Petra
Guest
 
Posts: n/a
Was it the fuse solve the problem? Wow, glad that I could actually help someone!
Reply With Quote
  #10  
Old 06-07-2001, 08:17 PM
JL
Guest
 
Posts: n/a
Petra you were quite correct ,& you did help someone. I thought I was looking at a very expensive problem. Again ,thanks very much for the help.

-John Lesko
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not Tech Question, 124 Driving Position, Can't See Instrument Cluster Michael K Tech Help 4 08-27-2003 01:59 AM
Instrument cluster removal in CLK430 oktane Tech Help 0 12-23-2002 04:18 PM
A small tip: Removing instrument cluster. carman850 Tech Help 5 11-06-2001 07:45 PM
Instrument Cluster Light Replacement Morphous Diesel Discussion 2 09-10-2001 02:48 PM
86 560 SEL Cooling system question gp56 Tech Help 4 01-03-2000 09:56 AM



All times are GMT -4. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page