Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-06-2001, 02:56 PM
Posts: n/a
I'm wondering if anyone can tell me what might be causing my power door locks to operate sporadically.....sometimes when I lock the car only the driver's side will work, othertimes they all lock. Doesn't matter whether I drive a long distance or short. It seems to have a mind of it's own...the car is a '72 280SE 4.5. Thanks!!!
Reply With Quote
Old 06-06-2001, 07:32 PM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Sounds like a vacuum leak...

in one of the door actuators.

Mine were sporadic also, after replacing two definitely blown units. The third unit had a small (very small) rub spot that apparently had a pin hole leak that would sometimes seal, sometimes leak.

Other vacuum points to check, the gas door diaphragm, trunk lock diaphragm, the check valve under the hood, all the rubber connectors for the vacuum lines. Only takes a good Saturday to go through it.

If you don't have a vacuum gauge or a hand vacuum pump, get one. Approx $40.00 for a good hand pump that you can use to pull a vacuum on the system. Disconnect the vacuum reservoir from the system when doing you testing, any leaks will be magnified due to the lack of reserve.

The easiest way for me to test each individual element was by pulling the door panels rather than cutting the hard lines or fishing the Y connectors out of the pillars (or pulling the glove box to get access to the lines. If you are careful and take your time you can de-skin the doors without damage (plus you'll have to open the doors up if you replace an element).

Hope this gets you started.
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon least its a diesel

Non illegitemae carborundum.
Reply With Quote
Old 06-06-2001, 09:14 PM
Posts: n/a
I'm not sure if your locking system is like mine or not, I have a 82 300D turbo, but if you check out this thread

82 300TD A/C problem
you will see how I chased down my leak. I found on mine that the component that leaked sometimes leaked off enough vacuume while the engine was running that other components did not work correctly. The part at fault was not the one that was acting up. I hope this helps you out.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power seat problem cil254 Tech Help 4 01-11-2005 09:45 AM
How I fixed my power antenna least temp Saint Car Audio and Multimedia 0 01-01-2005 02:41 PM
300e Power Window Problem cbpa40 Tech Help 1 10-12-2004 02:02 PM
'94 E 320 sedan...Power mirror problem unabrasive Tech Help 0 12-27-2003 02:01 PM
Power antenna problem shafers SL Forum 0 09-11-2003 03:20 PM

All times are GMT -4. The time now is 05:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page