Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-07-2001, 04:47 PM
mike webb
Guest
 
Posts: n/a
hello from mike webb , we have a 1997 e320 with 70k miles ,transmission is in limp , was able to capture a dropout on rpm sensors in the trans with a fluke98 , tried to capture again with 4 channel edge pac tool on sensor outputs + power + gnd , no , posted to I-ATN, + checked fix database , replaced conductor plate & trans filter & fluid , road test , at first no codes then po715 po720 , these codes are for trans rpm sensor or power supply to trans rpm sensors po715 & error in 1 rear wheel speed sensor which the tcm uses as a vss po720 , we can graph output of all above sensors & power & ground to the trans module at the same time with a multi channel labscope called EDGE SIMUTECH , other than a 500ms delay between startup on the rpm sensors from start there is no weirdness, the codes listed are not supposed to light until the rear wheel speed sensors reach 250 hz which should be about 12mph , but the codes comeback at the time of start up everytime , pin 38 which is power to the solonoids in the valvebody pulses a long 100ms then a short 50ms pulse (code 11) then drops to 0 when the key is switched to on , pin 38 remains @ 0 until the next time the key is switched on , this is the limp function of the trans module .there is serial data present @ the data pins in the trans module, we are clearing the codes thru the mercedesbenz dlc located in the fuseblock with a snapon mt2500 & mercedes software, to me the trans module seems to be bad ,but mbdoc thinks the snapon tool may not be clearing the codes from the tcm , the snapon tech people cant tell me yes or no , they are supposed to contact me monday am to verify which it is , from amsterdam ??? the trans module is pn 020 545 88 32 egs siemens, i have the waveforms stored in databases and they can be emailed if anyone is needing to see them to help with diagnoses . disconnecting the trans module overnight changes nothing ,
the trans module is $830.00 thru mercedes and i dont want to replace it on an very educated guess , i like to see a bad waveform or something actually broken , i am not seeing that .... can someone enlighten me and point me in the right direction .... thanks , mike webb , smile
Reply With Quote
  #2  
Old 07-07-2001, 07:29 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
For all the good equiptment you have hooked to it the thing you really need is a scanner that will talk to the trans. I have never heard of the code proceedure that you describe giving a code 11. I would not imagine that car to have any impulse type codes. You need to see some actual values I would think. Do you have access to a CS2000 or AST retriever?

As far as I have heard the Snap-on will only do OBDII and engine management. This might include transmission but I doubt it.

Since the code comes before you move I would expect a power or connection problem.

Seams like I remember a service bulletin on the rpm sensor but it could have been a BMW bulletin - something about its mounting.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 07-07-2001, 09:51 PM
metricman
Guest
 
Posts: n/a
1997 722.6 transmission

1997 was the first year for the 722.6 electronic transmission. To bad you are out of warranty. If the car has the original valve body and EGS control module, they should both be updated/replaced, not just the conductor plate. Other modifications that should be done are the B2 Piston/B3 housing modification and the stronger one-way roller clutches. Most likely many of the adaptation values are too high and then the clutch packs need to be tighten up. In my experience, most of the 1997 transmission need the whole works done.
Reply With Quote
  #4  
Old 07-07-2001, 10:06 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I had one of these wear me out as well. It turned out that we replaced the tranny and controller (because you have to replace them both on the 97 to get the updated controller). This fixed the problem.

Also, be sure the tires are evenly worn. IF one or two are a little more worn, IT will cause these speed sensor problems.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #5  
Old 07-09-2001, 11:29 AM
mike webb
Guest
 
Posts: n/a
update to replies , 1997 e320 trans codes

many thanks for quick replies , the code 11 may not be valid but according to mitchel on demand code 11 = code p0715 , which is = to power supply to the rpm sensors ,which i have measured as good many times , or it may be the dieing gasp of a bad trans control module , however when looking in the climate control modules of late 80s to early 90s mercedes 190 300 , the codes are on top of the reference voltage to the sensors , but they repeat endlessly while the key is switched to on.... i have not heard yet from SNAPON BALCO product / tech support as to the code clearing ability in the tcm , one other reply on iatn , looks like a bad trans control module + , tsbs or updates are not listed in MOD for this problem, i have contacted their product support for that data , there is no listing in the nhsta fedworld website for trans problems in this car , if anyone has tsb# s it would be helpfull in tracking them down , thanks a million , will post with results ,
Reply With Quote
  #6  
Old 07-10-2001, 06:29 PM
mike webb
Guest
 
Posts: n/a
FIX : new tcm ,

hello from mike webb , according to another local shop the current version (1199) snapon software does clear the codes in the trans module , the SNAPON BALCO support people are going to ship us a beta version of their new mercedes software that does interact with the trans module , we have ordered a new trans module from FREINDLY MERCEDES , the local mercedes dealer , $860.00 , they claim the module MUST be coded to the car with the HHT , even after the module is programmed to the vin # of the car by the folks at MERCEDES , ??? is this true ???? i have seen no mention of this anywhere else .... thanks - mike webb
Reply With Quote
  #7  
Old 07-10-2001, 07:25 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Many of the new software versions of aftermarket scanners are now doing the coding of new units. I haven't done any tranny controllers so I don't know which ones will do what. I definitely would expect that controller to need coding.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #8  
Old 07-12-2001, 12:44 PM
mike webb
Guest
 
Posts: n/a
SNAPON beta software , trans module codes

1000 thank yous , i have just recieved the new mercedes software beta version from SNAPON DIAGNOSTICS ,it seems we are still a beta site , i wasnt sure after the demise or absorbtion of EDGE DIAGNOSTICS by SNAPON DIAGNOSTICS , mercedes trans codes in the old tcm are as follows 008 ,gear /park solonoid 013 speed sensor n3 , 104 reverse gear / park solonoid , 109 speed sensor n3 , 120 rf vss from ecm inplausable , 121 lf vss from ecm inplausable , 132 ecm can comm or ect implausable , 135 can comm disturbed ;engine management , codes p0715 po720 are as before in the engine ecm , the new tranS module is not here yet ... codeing is availible in the SNAPON SOFTWARE ., i am about to test the circut for the reverse/park lockout solonoid .... between pin 4 & fuse 15 measures 26 ohms , there fore code 008 & 104 are "inplausable " to me , the tcm is bad , once again the creator has smiled on me .
also (this is addressed to stevebfl the moderator ) am i allowed to tell the people on iatn about this website ???
thanks again , mike webb
Reply With Quote
  #9  
Old 07-12-2001, 02:41 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Mike,

It has been mentioned on iATN in the past. Thats how I got here. Never hurts to keep everyone informed.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #10  
Old 08-06-2007, 12:51 PM
Registered User
 
Join Date: Oct 2002
Location: Texas
Posts: 303
diagnostic tool cost

Mike ,

Could you tell me where and how much this diagnostic tool cost? I have the same exact problem on my 97 e300 diesel - but the thing is my wife drove the car with a deflated rear tire- which what shot the tranny into limp home mode. I'm hoping that resetting the TCM codes would reset the CEL as well. Any suggestions?
__________________
a2


1978 280 CE silver
1986 560 SL black
1987 300 SDL cream
1994 SL 500 brilliant green
1997 E 300d dessert silver
2005 FORD F250 Superduty Crew cab 4x4

____ADMU____
Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E320 Climate Control OBD Codes Jon Hrut Tech Help 8 06-08-2005 09:16 AM
'98 E320 Power Steering and Trans. Leaks, M112 Engine DaveJ Tech Help 1 06-23-2004 10:39 PM
Transmission fluid wicking into computer on 1997 E320 95s420 Tech Help 2 06-03-2004 05:35 PM
1997 (W210) E320 ignition cuts out chamberlaini Tech Help 0 11-06-2003 04:05 PM
what mods are available for a 1997 mercedes E320? CarFanatic Performance Paddock 3 09-10-2001 06:23 PM


All times are GMT -4. The time now is 02:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page