Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-09-2001, 10:01 PM
handsworth's Avatar
420SEL "Big Boy"
Join Date: Jul 2001
Location: Suburban Cleveland, ohio
Posts: 117
Very glad to be a first time Mercedes owner. I bought a 1985 380se this past weekend and it is in very good condition, however there are two problems that I need fixed ASAP.First one is that it runs fast while in park or neutral ( about 1600 rpm) but as soon as I shift to reverse or drive, it drops to 600 rpm. After reading many posts here, I replaced the OVP and the idle slide valve. No change. Any suggestions? Also My central locking doesn't work. I know they are controlled by vacuum. They wiggle, but don't operate. Is this related?
Reply With Quote
Old 07-09-2001, 10:14 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Door locks on a 126 chassis are done through a reverse cycle pump. Pressure does one way and vacuum the other. The pump is in the trunk with the spare tire.

The idle control has its own controller those years and often just has bad solder connections on its PC poard. It is obviously not doing its job if the idle is up to 1600 and you have replaced the valve.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 07-10-2001, 07:26 AM
ymsin's Avatar
Driver, Mercedes-Benz
Join Date: Feb 2001
Location: Malaysia
Posts: 1,645
Sometimes it could also be because of the accelerator cable being jammed. Lube the links to free it - like it did for my dad's 126, and it worked well.
... Kerry

126 tailed by a 203, 129 leading the pack.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1967 230s idle problem techrondon Vintage Mercedes 17 03-29-2004 10:25 AM
190E temporary fast idle Greg in Oz Tech Help 1 07-31-2003 09:15 PM
fast idle, is this a sign of problems to come? jab Tech Help 2 01-24-2003 08:33 PM
Fast idle when warm, 2.3-16v Dan Rotigel Tech Help 1 03-04-2002 08:57 PM
Fast Idle Problem Cured! William B. Tech Help 1 11-11-2001 06:49 PM

All times are GMT -4. The time now is 01:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page