Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-27-2001, 03:32 PM
Registered User
 
Join Date: Jan 2001
Location: San Francisco
Posts: 26
Hi folks,

In my s420 1995, the MAX setting for the AC blower merely blows a negligible amount of air through the vents. My brother's C-class blows his hairpiece out of place at the MAX setting.

Are the blowers on the W140s designed not to blow hard? All vents check out ok and it blows cold air - it's just that it doesn't blow hard, so it takes a while before cooling the whole cabin. The rear vent also blows very slowly.

Is there an AC blower that I can replace mine with that blows harder?


thanks a mil.

jimSF
__________________
jimSF
Reply With Quote
  #2  
Old 07-27-2001, 04:28 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Remove the cover at the back of the engine comparment, pass side, in front of the windshield. There are about six big phillips screws holding it. The blower is underneath. On top of the blower is the regulator. It controls the current flow (speed) of the motor in response to the voltage signal sent by the pushbutton controller. This signal should be a 1 to 6 volt signal. They may go as high as eight volts but the one I tested last week wsa getting a little over 6v at max.

If your control voltage is right then the regulator is probably bad. (That is the very common answer to your problem). Another common problem is a air filter that is plugged.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 07-27-2001, 05:25 PM
David C Klasse's Avatar
CheFrac is Back!
 
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Or you could also simply try and see if your cabin filter is old/clogged, or in need of replacement. This could restrict air flow.
__________________
2006 E350 w/ 155k miles (Daily Driver)

Previous:
1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
  #4  
Old 07-27-2001, 10:46 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,925
. . .check this thread

should answer all of your questions, complete w/ picture: A/C blower's output is low . . .
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #5  
Old 07-30-2001, 10:51 PM
Registered User
 
Join Date: May 1999
Location: Somers, CT
Posts: 73
See the JimF thread, posted earlier.

I followed his advice and procedure and everything went
very well.

You will need a large philips screwdriver and a T-20 torx.

As a rehearsal, I removed the cover and the air filter
to make sure that I could see the part and all the
connections. THEN, I ordered the part here from
the website. I also ordered a new air filter.
The new part (blower regulator) was $238.00 and the
filter was about $38.00.

You will probably want to provide the VIN number so
that you will make sure that you get the correct part.

I figure that I saved about $500.00 for the dealer
solution of replacing the blower assembly.

Thanks JimF and the Mercedes Shop!
__________________
Ralph Burnette
1993 300SD (286k + miles)
2000 SL500
2001 ML320
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
S-Class Fiasco: W220 vs W140 A. Rosich Tech Help 295 12-10-2012 06:49 PM
W140 3.2L ENGINE from a 500S in to a W140 300SD???? ricardo Diesel Discussion 3 11-28-2004 06:14 PM
W140 Sorin Diesel Discussion 6 07-21-2004 10:50 PM
1992 - 1999 W140 change list.... I need your helps..... akry Off-Topic Discussion 5 06-13-2003 03:34 AM



All times are GMT -4. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page