Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-24-2008, 09:08 PM
Registered User
 
Join Date: Mar 2008
Posts: 17
intermitant ASR problem 1993 500sl

I just completly rewired my engine harness on my 1993 500sl because of an intermitant asr problem.
Now my asr light stayes on all the time. Do I have to reset it and if so how do I do it.

Sal
ps I just want to list this under eta also

Last edited by salsaia; 04-03-2008 at 12:56 PM.
Reply With Quote
  #2  
Old 03-25-2008, 12:13 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,923
Do you mean that you "replaced" your engine wiring harness??

If you re-wired it yourself. . (big job!!!!), then my question is why did you DIY?

In any event, follow the procedure that detailed in MENU#24 on my web pages. Your ETA may be going bad as the root cause of the ASR light.

Dump the codes in the ECUs indicated and see what DTCs are stored.
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #3  
Old 03-25-2008, 02:32 PM
Registered User
 
Join Date: Mar 2008
Posts: 17
I rewired the ETA unit from the circuit board back. The unit looked ok visualy,including the potentiameter. Is there any test you can do electricaly on the ETA?

Sal
Reply With Quote
  #4  
Old 03-25-2008, 04:08 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,923
Quote:
Originally Posted by sal
rewired the ETA unit from the circuit board back. The unit looked ok visualy,including the potentiameter. Is there any test you can do electricaly on the ETA?
Not sure what that means?? "from the ckt board 'back'"?? Do you mean from the ckt board to the output connector?? If yes, did you rewire the pins in the connector??

There are tests but you need somebody who has a "jig" to properly test the ETA's operation. One such place is "Beckmann" (link in MENU#24). They charge $40 to test one. If you have a "working" car similar to yours, you could test it in-situ . . but that's alot of work.

So you DIDN'T replace the wiring harness?? If not, that should be done asap. Actually it should have been done first!
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #5  
Old 03-25-2008, 07:33 PM
Registered User
 
Join Date: Mar 2008
Posts: 17
Jim
when you say the wiring harness do you mean from the plug{next to the computer box} to the engine.I did replace all the wiring from that plug except for the wiring going to the injectors.
The asr light was interment before I started the job, now it is on all the time

What do I do now?
Can I just eliminate the asr completly?
Sal
Reply With Quote
  #6  
Old 03-25-2008, 08:07 PM
Registered User
 
Join Date: Aug 2003
Location: Phoenix
Posts: 3,726
There is a slick way to eliminate the ASR completely - sell the car. Until then you need to pull the fault codes as Jim suggests.
Reply With Quote
  #7  
Old 03-25-2008, 08:48 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,923
Quote:
Originally Posted by salsaia View Post
Jim
when you say the wiring harness do you mean from the plug{next to the computer box} to the engine.I did replace all the wiring from that plug except for the wiring going to the injectors.
What do I do now?
Here's a pictorial on the engine wiring harness. Study it, buy one and replace your old one .
http://www.peachparts.com/Wikka/M104WireHarness
Of course, this is for a M104 but it illustrates that your version has a lot of 'tentacles'.

Quote:
Originally Posted by salsaia View Post
Can I just eliminate the asr completly?
Sal
Yes, take deanyel's suggestion! Seriously, no, it's NOT the ASR, it's the ETA.
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page

Last edited by JimF; 03-25-2008 at 11:23 PM.
Reply With Quote
  #8  
Old 03-25-2008, 09:54 PM
speace's Avatar
Member
 
Join Date: Jan 2003
Location: Atlanta, GA
Posts: 370
Quote:
Originally Posted by salsaia View Post
I just completly rewired my engine harness on my 1993 500sl because of an intermitant asr problem.
Now my asr light stayes on all the time. Do I have to reset it and if so how do I do it.
Sal
EDIT: Much of this post is not relevant since the 92 and 93 ASR systems are different.
************************
I am basing my comments on the presumption that the 93 500SL is the same as my 92. I believe the harness you rewired would be the leads from the ETA (Electronic Throttle Actuator) to the control unit. Yes, these wires like to crumble...

In saying that the ASR light stays on I also presume the car stays in "Limp Home" mode. Unfortunately, you can't just disable the ASR since it is integral to the operation of the car...

Logic would say that you have a wiring problem in your repaired harness. You may find yourself purchasing a new ETA which includes some of the wiring. Hopefully your control unit has not become damaged in the midst of this...

The only wiring information I was able to locate did not give pinouts, but indicates there are 7 wires. 2 for the DC actuator motor, 2 for the saftey switch, and 3 for the position sensor potentiometer.

Unfortunately, I am told there are no codes to be read from the control unit on these early models. If someone knows otherwise, please direct me to the information!

Good Luck!
__________________
02 S500
92 500SL
92 400E
87 300E (Sold)
83 300D Turbo (Sold)
75 300D (Sold)
74 240D (Sold after 20 years)
65 Mustang 5.0 (w/Electronic Fuel Injection)

Last edited by speace; 03-27-2008 at 06:56 PM. Reason: Added disclaimer that the info was not for a 1993 SL
Reply With Quote
  #9  
Old 03-26-2008, 07:34 PM
Registered User
 
Join Date: Mar 2008
Posts: 17
I GIVE UP!!!
I rewired most of the engine comp.--same problem
. I tried tape on pins-- the same problem. I tried to disconnect the brake light switch--same problem
I don't know what to next about my asr siduation.
I am about ready to get rid of the car.

Does any body have any more suggestions?
Thanks

Sal

ps I would be happy without any electronics in my car if this would be possible.
Reply With Quote
  #10  
Old 03-26-2008, 07:45 PM
speace's Avatar
Member
 
Join Date: Jan 2003
Location: Atlanta, GA
Posts: 370
It CAN be fixed, but it isn't really a DIY project...

Where are you? Perhaps someone can recommend a reputable shop to help.
__________________
02 S500
92 500SL
92 400E
87 300E (Sold)
83 300D Turbo (Sold)
75 300D (Sold)
74 240D (Sold after 20 years)
65 Mustang 5.0 (w/Electronic Fuel Injection)

Last edited by speace; 03-27-2008 at 07:00 PM. Reason: Removed comments that were 1992 specific - this is a 93SL...
Reply With Quote
  #11  
Old 03-26-2008, 08:15 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,766
Just go into the EA/CC/ISC control module and get the codes ..
They are right there ...'93/500sl/Chassis 129.067................

Pin # 7 on the 38 pin Diagnostic Port.

Page 48..AE/CC/ISC w/ASR .
http://www.geocities.com/MotorCity/Downs/1039/mercedes/cs1000_mb.pdf

Get a $2 led at Radio Shack and build the tool..
Post findings.
__________________
A Dalton
Reply With Quote
  #12  
Old 03-26-2008, 10:59 PM
speace's Avatar
Member
 
Join Date: Jan 2003
Location: Atlanta, GA
Posts: 370
Quote:
Originally Posted by Arthur Dalton View Post
Just go into the EA/CC/ISC control module and get the codes ..
They are right there ...'93/500sl/Chassis 129.067................

Pin # 7 on the 38 pin Diagnostic Port.

Page 48..AE/CC/ISC w/ASR .
http://www.geocities.com/MotorCity/Downs/1039/mercedes/cs1000_mb.pdf

Get a $2 led at Radio Shack and build the tool..
Post findings.

Arthur,

Are you saying this applies to my 92 as well?
Where can I get a CS1000 Scanner?
__________________
02 S500
92 500SL
92 400E
87 300E (Sold)
83 300D Turbo (Sold)
75 300D (Sold)
74 240D (Sold after 20 years)
65 Mustang 5.0 (w/Electronic Fuel Injection)
Reply With Quote
  #13  
Old 03-27-2008, 01:09 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,766
What do you want a scanner for??
You build a led/sw tool for $10 to get the codes...
They are Flash Format.
__________________
A Dalton
Reply With Quote
  #14  
Old 03-27-2008, 01:13 AM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,923
Quote:
Originally Posted by salsaia View Post
I GIVE UP!!!
I rewired most of the engine comp.--same problem
. I tried tape on pins-- the same problem. I tried to disconnect the brake light switch--same problem
I don't know what to next about my asr siduation.
I am about ready to get rid of the car.

Does any body have any more suggestions?
Thanks

Sal

ps I would be happy without any electronics in my car if this would be possible.
I guess you don't read that well. . . you need to buy a wiring harness that's made for your car (they are different with different models/years) and install it carefully removing the old one as you go.

Read the stored codes and report them here. Then I can help you with the ETA repair.

SPEACE: You "came" in implying that you were knowledgeable in this area. . . but it's painfully obvious, that you know nothing of what's going on.

If your car is having a problem, you should start a new thread and we can help you. Purchasing a CS1000 . . . indeed!! Buy two, they're small!
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #15  
Old 03-27-2008, 12:48 PM
Registered User
 
Join Date: Mar 2008
Posts: 17
I am in jupiter fl.
Does any one know of a good shop in this area that could help me with my asr problem?
THANKS

Sal
Reply With Quote
Old 03-27-2008, 12:48 PM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page