Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-07-2001, 11:33 AM
Jason M.
Guest
 
Posts: n/a
Looking for common problems on 190E 2.6

Hey everyone,

Im going to be working on a friends 190E 2.6 and hes having hard start/ rough idle/ no power problems with his car. I haven't looked at it yet, but are there some things to keep an eye out for so we don't change 100 needless parts trying to eliminate the problem? We'd like to take a diagnostic approach to this if at all possible. I appreciate the input




Jason M.
Reply With Quote
  #2  
Old 08-07-2001, 12:15 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Without actually being there, I would hone in on the ignition system. Bad spark plug wires and ignition coils contribute to those symptoms you described.

Check all connections throughout the ignition path to see if all is well. Check the plugs as well. Improper gap setting will impair performance under load.

After that, I would move on to the fuel delivery system. The filter is the cheapest (and most overlooked) cure for many fuel related problems.

I save the expensive engine management systems for last, after I've ruled out the lesser, more easily serviceable parts.
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #3  
Old 08-07-2001, 08:19 PM
Clauser1
Guest
 
Posts: n/a
I'm w/GBenz.However,make sure that the 02 sensor
and the EHA is in good wroking condition.
Reply With Quote
  #4  
Old 08-07-2001, 10:04 PM
Jason M.
Guest
 
Posts: n/a
Thanks, I'll check it out


Jason M.
Reply With Quote
  #5  
Old 08-07-2001, 11:58 PM
Senior Member
 
Join Date: Apr 2001
Location: Beech Island, S.C.
Posts: 468
Check the fuse in the overvoltage protection relay first.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
87 190E 2.6 hard starting problems. Ralph Todd Tech Help 11 11-07-2008 10:25 PM
190E 2.6 info needed pentoman Tech Help 6 01-31-2005 08:53 AM
Flywheels... 300E-24 Vs 190E 2.6 sportline... Bigg_P Performance Paddock 1 01-28-2003 10:21 PM
Is there a worthy replacement for the 190E 2.6? Marsala Featured Cars 15 06-04-2002 09:12 AM
1991 190E 2.6 Starting Problems aklim Tech Help 4 03-10-2002 11:21 AM



All times are GMT -4. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page