Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-07-2001, 11:46 AM
RDawson
Guest
 
Posts: n/a
Angry Sticking indicator

My wife has a Mercedes 300 SL (W129). The left hand turn indicator lights of its own free will! The indicator light on the dash and the external lights will even stay on after the ignition is turned off!

I have a clifford alarm on it which still flashes all the indicators.

The stalk has no effect when the light is stuck on, but works correctly when it is not and the hazards work correctly.

The dealer has had a look but cannot find any fault as it did not perform for him.

He has tried disconnecting the alarm from the indicators, but the problem still occurs.

The original factory alarm was disconnected very recently.
Reply With Quote
  #2  
Old 08-07-2001, 06:44 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
There is a "red fische" bulletin to MB dealers on this subject!! The combination relay can have a mind of it's own & keep the lamp on.
The topic number is 82A92111 on the old red fische!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 08-08-2001, 04:43 AM
RDawson
Guest
 
Posts: n/a
Thankyou!

I will inform my dealer. This is the last time I use a main agent for work on my car. They should have known this, especially at the prices they charge.

kind regards
Reply With Quote
  #4  
Old 08-08-2001, 05:18 AM
RDawson
Guest
 
Posts: n/a
M.B.Doc

I have spoken to my Dealer who says UK cars and US cars are different and so the bulletin is irrelevant! They are so patronising.

I think I will tell them where to go. Is it possible to have a copy of the bulletin?

Is the combination relay on a W129 the same as other combination relays on Mercs?

kind regards
Reply With Quote
  #5  
Old 08-08-2001, 09:29 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Both rt hand drive & US cars use the same relay, part number 129-820-10-26. UNLESS the production date code on your relay is above week37 of 1992 it is defective.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #6  
Old 08-08-2001, 10:59 AM
RDawson
Guest
 
Posts: n/a
THANKYOU
Reply With Quote
  #7  
Old 08-08-2001, 05:12 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,746
I hesitate to suggest something so obvious -- are you sure it isn't the headlight switch set to the most counterclockwise position? I don't think this would cause the dash indicator to light, though.

Sixto
91 300SE
Reply With Quote
  #8  
Old 08-09-2001, 05:03 AM
RDawson
Guest
 
Posts: n/a
I am sure. It is the turn indicator that is sticking on, not the parking lights.


Thankyou anyway.
Reply With Quote
  #9  
Old 08-09-2001, 08:09 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,746
And of course the park lamp of your nonUS car is part of the headlight, not the corner light. A different element in the rear too.

Sixto
91 300SE
... and egg on my face
Reply With Quote
  #10  
Old 08-10-2001, 04:59 AM
RDawson
Guest
 
Posts: n/a
no worries
Reply With Quote
  #11  
Old 08-10-2001, 03:00 PM
A. Rosich's Avatar
Registered User
 
Join Date: Nov 1999
Location: San Jose, Costa Rica
Posts: 883
Just a comment: my previous 1986 W124 300TE (Euro spec) had exactly the same problem!

The official M.B. dealer here changed the combination switch and it was solved.

Not a cheap solution, but it worked.

A. Rosich
S320, 1998
E320T, 1995
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W140 washer level indicator sixto Tech Help 3 09-01-2003 06:48 PM
86 300E indicator lights on - alternator prob? jrmd01 Tech Help 15 06-22-2003 11:00 PM
Help to diagnose exterior light failure indicator on 87 W126. ivorysdl Tech Help 0 02-19-2003 10:30 PM
Question on "bulb out" indicator 300EE320 Tech Help 6 10-04-2002 12:36 PM
Light indicator problems Snibble Tech Help 2 04-10-2002 09:21 PM



All times are GMT -4. The time now is 04:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page