Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-24-2001, 09:36 AM
Posts: n/a
Instrument panel lights

Help!!! This is a 1991 190E 2.3 237,000 miles
The lights on AC controls, Radio buttons,etc don't come on with the headlights. The speedo instrument cluster works fine.
They did work far a few days once but when I switched the rear window lockout switch, they went out and have not worked since. Just before they started working, I had the console plate off and was replacing window switches. Then while driving, they came on suddenly and worked until I moved the window lockout switch. The fuses are all good and the bulbs are good.

Read some of the threads on this problem. Might be light in fiber optics. Got the wood panel off, but can't figure out the removal of the climate control panel. Need guidance.

Last edited by bryantmt; 08-24-2001 at 08:24 PM.
Reply With Quote
Old 09-04-2001, 04:56 PM
dpetryk's Avatar
Electrons can do anything
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,071
I had a similar problem with my 19 420sel. It turned out to be a bad connection on the printed circuit board in the instrument cluster. The dimmer module plugs on to the back of the instrument cluster and where the pin was soldered to the PCB was bad. I had to repair that connection. It was delicate electronic work and I dont recommend it if you are not familiar with this type of work. Good luck
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
instrument panel and brake light failure rsc Tech Help 4 08-22-2003 07:12 PM
Gauges on instrument panel swing wildly Marvin Smith Tech Help 7 06-22-2003 01:35 PM
'92 300 E - No Instrument Cluster Warning Lights at Startup jgl1 Tech Help 1 06-27-2002 09:42 AM
Wierd instrument panel illumination problem. Benzima Tech Help 2 03-26-2002 10:32 AM
How to check the oil level from the instrument panel on a W202 Richard_D Tech Help 0 08-06-2001 11:07 AM

All times are GMT -4. The time now is 08:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page