Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-07-2001, 08:00 PM
Registered User
 
Join Date: Feb 2001
Posts: 162
Question W124 Battery Discharging - ideas?

Hi all.. I have checked the previous history of the forum and not yet got very far with this one...

I have a W124'95 E320 Wagon, and it's (new!) battery is discharging over a 48 period.

No warning lights when starting/driving informing me of battery "non-charge" situation...

Sooo... where do I start to look? Has anyone else had this and fixed it before?

I'm not "real" mechanic, but I *do* have the W124 CD's and I *Will* do the work ...When I can! ;-)

thanks in advance!

>Joe
__________________
>Joe

http://www.bonnemay.co.uk/pics/W123_48.gif
1984 W123 230E Saloon/Sedan! (82k miles - Ice Blue as new)
1985 W123 230TE (96K miles - stinkingly nice!)
1995 W124 E320 Wagon (130k miles)
Future projects:
Sportline Suspension W124, W123 TE restoration, A/C, cruise & powered seats retrofit!

>Based in the UK!
Reply With Quote
  #2  
Old 09-07-2001, 09:37 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
How old is the battery first and foremost.

2nd..

Check any door and or trunk pin switches as they can fail and sometimes allow the battery to drain by leaving an interior light on.

Most times its the trunk one and thats why people can't find it. Can't tell the trunk light is on when the trunk is closed.

I hope that helps you get started on tracking down this problem. A Dying battery can be annoying.

Have you had the charging system checked?

Alon
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #3  
Old 09-08-2001, 04:35 AM
Registered User
 
Join Date: Feb 2001
Posts: 162
Thanks for the reply...

Sorry, the battery is less than 6 months old.

No interior lights are on when locking up, as it's a wagon, it's pretty easy to see this...

I was hoping to hear from the group if there were any more things I could do to check the charging system before I go to my mech.

Any more ideas folks?

Thanks in advance
__________________
>Joe

http://www.bonnemay.co.uk/pics/W123_48.gif
1984 W123 230E Saloon/Sedan! (82k miles - Ice Blue as new)
1985 W123 230TE (96K miles - stinkingly nice!)
1995 W124 E320 Wagon (130k miles)
Future projects:
Sportline Suspension W124, W123 TE restoration, A/C, cruise & powered seats retrofit!

>Based in the UK!
Reply With Quote
  #4  
Old 09-08-2001, 04:48 AM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
 
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
Just went through this with our Toyota. The tech checked for a short (nope), a good ground wire from the battery (good), and the regulator and alternator (BAD DIODE in alternator). Replaced the alternator. He said a battery, even if new, can be damaged by a full discharge, and to see how it worked out over the next week or so, as it may need replacing as well. Good luck!
__________________
John

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
  #5  
Old 09-08-2001, 07:50 PM
dlswnfrd
Guest
 
Posts: n/a
I Know How You Feel

Brother of the Benz,joeywarren
Reply With Quote
  #6  
Old 09-08-2001, 08:24 PM
Registered User
 
Join Date: Sep 2001
Location: Seattle Washington
Posts: 24
Hello,

Question, Does this car have a power antenna?

I had a BMW who's antenna motor didn't shut off completely, contacts didn't open all the way when the antenna was in the down position.

No sound of the motor running or anything.

This happened to me twice in about 5 years.

Put your hand on the antenna motor it maybe hot.

Good luck
Reply With Quote
  #7  
Old 09-09-2001, 02:57 PM
Registered User
 
Join Date: Feb 2001
Posts: 162
All - thanks for the help.

Sorry for the delay in getting back, I have been away at a concert! I even used the car to get there - a bit of a risk.. buuut - whilst there, I solved the problem.

A dodgy earth wire in the trunk from the CD changer to the earth point had fried - looks like I used the wrong guage wire... and hence was discharging the battery by a "slow cooking" method... lucky it didn't cause a fire...


It has got me thinking about other potential (pre-me!) DIY bodges that I may need to check out upon your advice... power antennas, fuses (locating power problems with a meter.. I have one.. yes).. I think I will do the "full monty" and ensure we all safe in there.

Thanks again 92400E, tkamiya, dlswnfrd (brother of the Benz??) - cheers & if you have any other W124 wagon general advice - let's hear it!

CHeers

>Joe
__________________
>Joe

http://www.bonnemay.co.uk/pics/W123_48.gif
1984 W123 230E Saloon/Sedan! (82k miles - Ice Blue as new)
1985 W123 230TE (96K miles - stinkingly nice!)
1995 W124 E320 Wagon (130k miles)
Future projects:
Sportline Suspension W124, W123 TE restoration, A/C, cruise & powered seats retrofit!

>Based in the UK!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing my ML's Battery? jmarkisz ML, GL, G-Wagen, R-Class, Unimog, Sprinter 6 04-29-2004 11:54 AM
Battery maintainer and switched 12v outlets ard Tech Help 6 03-24-2004 10:58 AM
Interstate battery fitment problem in '95 E420 DuckMuck Tech Help 18 11-05-2003 02:37 AM
Sudden loss of Battery Fluid 94MEBEe320 Tech Help 2 04-22-2003 03:18 PM
1991 300SL M-Benz Battery!!! spins23 SL Forum 5 04-19-2003 09:03 PM



All times are GMT -4. The time now is 11:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page