Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 01-01-2002, 11:30 AM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Sounds like a tricky one. Need someone who knows how to diagnose a car and not simply "replace parts". The shotgun approach can be quite effective, but MAN that ammo is expensive!
I am not suggesting the car can be repaired over the net, either. Need that personal touch sometimes.
It does sound a little like a symptom I have seen though on 190's. Does it act like this while driving as far as a difference between "normal" acceleration (bogs out) and if you really "baby" the throttle? What I have seen in cases like this is a plugged catalytic converter or muffler. No damage (kinks) in the exhaust system? One cheap way of testing this is to loosen the exhaust system from the exhaust manifold and try driving it then. Just loose enough so you get maybe 1/4" clearance between the front pipe and exhaust manifold.
On the 2.3, be very aware of the possibility of a blown head gasket. Look for oil in the coolant tank, that's usually the first sign.
Has the on-off ratio (lambda) been correctly set? CORRECTLY is the key word there.
Make sure the correct spark plugs have been used, I don't care what the parts-replacers say about the scope.
Please no more "PPPLLLLLEEEAAASSSEEE!!!" type whining, very unbecoming to a Mercedes owner, even a 190 owner (oh, did I say that??)
Gilly
ps I have seen with the plugged cat problem that top speed will also be affected. I have seen them top out at only 50 to 60 mph, so be aware of this. I believe your 85 has the 2 cats on the very front of the front pipe (can be seen fron under the hood) these are prone to plugging.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wagon rear suspension valve rebuild lrg Diesel Discussion 11 10-04-2006 07:02 AM
Strange Fuel distributor problem 190E sonnybuddy Tech Help 11 04-21-2004 07:47 PM
86' 190e 2.3 8V fuel mixture adjustment kjsabat Tech Help 1 11-21-2002 04:13 AM
M103 Valve guides edbardzik Tech Help 3 06-01-2000 08:37 AM
300e Fuel System Problems marzilli Tech Help 3 02-12-2000 01:37 PM



All times are GMT -4. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page