Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-30-2001, 09:44 PM
kgschmid
Guest
 
Posts: n/a
Question 560 SL Questions

I recently bought a 1989 560 SL with 68,000 miles. I have handful of problems I am trying to fix would appreciate any help. First, my rear brakes squeal something terrible. In particular it seems to be worst when I am making a turn at slow speeds (5-10 mph). I have replaced the pads and have the anti-squeal past on them but it doesn’t make any difference. The noise often happens right after I have let off the breaks. I am think of replacing the bearings but would rather not go through the hassle if there is something else going on. Any ideas?
Another problems may all be related. First the odometer and trip meter have quit working. The speedometer does work. From reading some of the other forums it appears that this car has an electronic speedometer and odometer? Second, the cruise control does not work. And finally there is strange noise that seems to be coming from the rear of the car. It comes and goes but seems to start if I accelerate hard or hit a bump in the road. It sounds very much like a speedometer cable that needs to be lubed and changes speed and pitch with the speed of the car. The sound goes away if I bring the car to a compete stop. It will then not make any noise, sometimes for days. I am wondering if these problems could all be related to the speed sensor.
Reply With Quote
  #2  
Old 10-31-2001, 04:59 PM
MIKE FREEMAN
Guest
 
Posts: n/a
I HAVE THE BEST LUCK REGARDING BRAKE SQUEEL WITH PAGIG PADS AND BALO ROTORS NO PASTE.
YOU SAID THE NOISE HAPPENS WHEN YOU LET OFF THE PEDAL,CHECK FOR BROKEN SPRINGS OR DRAGGING SHOES IN PARKING BRAKE.
I DON'T THINK YOU WANT TO BE REPLACING THE BEARINGS YOURSELF (8HRS. BOOK TIME WITH SPECIAL TOOLS)
REGARDING THE SPEEDO CABLE NOISE,YOU DON'T HAVE ONE!
CHECK THE CENTER SUPPORT BEARING.
REGARDING THE ODOMETER THERE IS A PLASTIC GEAR AT THE END OF THE ODOMETER SHAFT THAT BREAKS WITH AGE,A GOOD SPEEDO SHOP CAN HELP YOU THERE.
MF
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Three Questions about 560 SEL ('89) hbofinger Tech Help 18 06-16-2004 03:29 PM
Several Questions From a Relatively New Owner of 560 SEL rtoddholden Tech Help 2 11-14-2003 08:50 PM
560 sl questions larrysiny SL Forum 7 11-14-2001 11:19 AM
just acquired 560 sel - questions chris560 Tech Help 4 10-06-2001 11:00 AM
A number of questions related to 560 SL abekani SL Forum 2 09-12-2001 03:23 AM



All times are GMT -4. The time now is 06:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page