Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-11-2001, 06:37 PM
Posts: n/a
Smile ABS Light after applying brake -90 560SEL- Solved

The ABS indicator lamp goes out when I start the vehicle and it comes on when I depress the brake pedal for the first time and stays on after that. I have checked the OVP Relay. Voltage is not undervoltage (13.8V). The Solenoid Valve Relay in the Hydraulic Unit is closing and is remaining closed even after the light comes on. The service manual doesn't cover this condition in the troubleshooting section and the tests that it calls out requires a special test set. Any guesses on what can cause this failure or any tests that I can run. Thanks, John

Edit: Heres how I solved it.
I found a post on another forum where someone had the same problem and they found it to be a brake light problem. So I checked the brake lights and sure enough I have one out! But why didn't the exterior light failure lamp light up? Because the ABS lamp and the exterior light failure indicators were swapped in the instrument panel. The previous owner probably had a dash light replaced and the indicators come out pretty easy. They probably just put them back in where they thought they went.
One of the clues that should have helped me was that the Solenoid Valve would not have remained closed if the ABS sensed a failure. It would have shut the hydraulics off.
I have to believe that the person with my same problem also had the indicators swapped and never knew it.

Last edited by jbrady; 11-12-2001 at 11:04 PM.
Reply With Quote
Old 11-11-2001, 07:10 PM
ymsin's Avatar
Driver, Mercedes-Benz
Join Date: Feb 2001
Location: Malaysia
Posts: 1,645
When the lights come on for the ABS - the first thing I do is to go into the workshop for it to be checked. The classic symptoms are as what you described and the solution varies in part.

The most common solution when this happens to the 124 is to check the ABS sensor - sometimes the sensor is dirty and needs a clean, or sometimes the sensor wires are a suspect.

The OVP rarely has a hand in this.

Its still safe to drive for now but don't do any hard driving on grass areas or wet surfaces.
... Kerry

126 tailed by a 203, 129 leading the pack.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 E320 right brake light Kept breaking for No Reason! Maruzo Tech Help 15 09-14-2004 08:34 PM
1991 560sel Abs & Asr Light On When You Start Vehicle mrtony Tech Help 1 02-26-2004 07:52 AM
W126 - ABS light on after battery change. OneTwoSix Tech Help 3 02-06-2004 12:21 PM
ABS Light on & Cruise Control Inop. y2kimmel Tech Help 0 09-03-2003 01:43 PM
1987 560SEL High Idle & Anitlock Brake Light On Steve Konizer Tech Help 1 02-26-2002 10:38 PM

All times are GMT -4. The time now is 09:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page