Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-09-2001, 01:11 PM
Registered User
Join Date: Dec 2001
Location: GA
Posts: 3
cruise control

I recently purchased my first MB, a 1990 300ce. Since then I have been reading posts on this board and have learned quite a bit.

I tried to use cruise on the hwy, but found that while it will engage, it will not smoothly maintain speed and turns off completely after about 1/4 mile. I tried to locate the CCA board, but could not find it. My intention was to re-solder the board. (I had seen this suggestion on another post.)

Also, does anyone have a suggestion for a repair manual? I have seen several on cdrom and also an English Haynes.

Thanks in advance.
1990 300ce
Reply With Quote
Old 12-09-2001, 01:39 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
This site has a number of interesting articles on cruise controls, how to locate the components, how it all works, and rebuilds them for you as well with a 4 year to lifetime warranty (See specials section).

The factory CD rom has a lot of info, but is a bit hard to use from what I hear. I don't know if your 90 came with all it's books, but my 87 has a book that basically shows exploded diagrams of most of the car's components and assembly that is useful. Also, www.************************ will let you fill out an online catalog request - the catalogs for W124s used to have exploded diagrams with part names and prices that was helpful on several occasions. Ebay also is a source for missing manuals, and occasionally for tech shop manuals on your car. (Those coupes are great looking cars!)


2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E

Last edited by JCE; 12-09-2001 at 03:30 PM.
Reply With Quote
Old 12-09-2001, 07:41 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Its behind the lower dash cover, drivers side next to the steering column. Get a manual (the CD is fine) for getting the dash cover off, it's a pain.

Usual problem is cracked ground connection -- flimsy construction.

Also, it is rumored that only OEM (Osram) tail-light bulbs should be used -- the control circuit grounds via the stop lamp filaments. The CC turns off when the lamps come one, but if there is too much resistance in the lamp filament, the CC won't work properly. This is a debatable topic (see other posts!), but it is worth checking the condition of the stop ligh bulbs -- if the base is corroded the CC won't work.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
Old 12-29-2001, 12:39 PM
Registered User
Join Date: Dec 2001
Location: GA
Posts: 3
re-solder cruise amp

I bought a CD-ROM, pulled the dash and re-soldered the CCA board in my 300ce. Before replacing the dash I took the car for a road test. The cruise control worked like new and I reset it at several different speeds...
I tapped the brake in order to disengage cruise and attempted to test "resume", but without any response. At this point the cruise control stopped responding altogether. I placed the car in park, turned off the ignition, checked all the connections, but still no cruise control.
Could this be the Hall sensor? Could the switch have gone bad? Does it make sense for a second problem to arise in the midst of correcting the first? Is it possible that I cracked the ground connection and where would I find the ground connection.

Thanks in advance.
1990 300ce
Reply With Quote
Old 12-29-2001, 04:37 PM
jbaj007's Avatar
Registered User
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
Same CC problem here. It works perfectly in ALL functions except if you tap the brakes (Osram regulation bulbs) it won't work until you restart the car. Anyone had the same thing and cured it?
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control - Normal Behavior ? DougLL Tech Help 2 06-24-2003 03:02 PM
Cause of odd ABS problem tied to cruise control? Ron Brooks Tech Help 3 01-03-2003 01:19 PM
Cruise Control Supposedly never worked right on my car...???? 190D22 Diesel Discussion 7 12-28-2002 04:13 PM
83 300D Cruise Control rmmagow Diesel Discussion 1 06-20-2002 11:47 PM
Cruise Control Trouble- '90 300D mike456 Tech Help 1 06-11-2000 09:22 PM

All times are GMT -4. The time now is 09:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page