Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-11-2000, 01:15 AM
Posts: n/a
I recently have started having trouble with my cruise control. Typical behaviour is something like:

- Cruise control will not engage with accel/decel or resume until AFTER engine is stopped and restarted (never works after car has been sitting for several hours and then started)

- Once engine is restarted it will engage, then sometimes it will accelerate by itself automatically (without me touching the accel), or it might work for a few minutes or it might just not hold the set speed. It may stop working by itself, and then start again without warning (to previously set speed) - this can happen within the space of 5 seconds

- For about 1 hour after restarting these effects are very irritating - after about an hour it will settle down and actually work properly for the remainder of the excursion.

I've tried taking out the cruise control unit (under the driver's side dash) and resoldering all the leads to all components. This just made it stop working completely.

Next I tried a known working cruise control (same model) from a '91 300D. This one works great - problem is I have to return it.

My next round consists of replacing the transistors, the LM2901N IC, and the ITT v8001-501 IC. My question is:
- Is there anything else I should change?
- Where can I find a ITT V8001-501? I've tried Digikey, Future/Active, radio shack, and the ITT website - no dice.
Reply With Quote
Old 06-11-2000, 09:22 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Be sure that the brake pedal switch is OK. They are weird like that sometimes.

If not, check the amp, as you have. The I/C chips are commonly the failure.

Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
87 300D cruise control jitters SHARK1007 Diesel Discussion 3 07-14-2004 12:04 PM
Surging Cruise Control on '85 300D lietuviai Diesel Discussion 4 09-23-2003 11:38 PM
Cruise Control 1987 300D Turbo William Curling Tech Help 3 11-01-2001 09:04 AM
Aftermarket cruise control Mercedes Man Diesel Discussion 4 10-10-2001 09:02 AM
300D cruise control Ric Tech Help 2 08-31-2000 06:38 PM

All times are GMT -4. The time now is 07:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page