Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-19-2001, 02:01 PM
Registered User
Join Date: Apr 2000
Location: Minnesota
Posts: 92
Installing a new Speedocable

I am planning to install a new speedocable this weekend because it is causing loud humming sound behind the speedometer. I need to know how would I go about doing this
job? Is this a DIY? thank-you

Reply With Quote
Old 12-20-2001, 07:00 AM
Posts: n/a
You will get much more accurate advice if you tell us what year and model MB you are working on.

Have a great day,
Reply With Quote
Old 12-20-2001, 09:19 AM
Registered User
Join Date: Apr 2000
Location: Minnesota
Posts: 92
OOps...Sorry, it is a 86 190E 16V. thank-you very much

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Order for installing evap box in a W123. dmorrison Diesel Discussion 17 12-31-2005 09:32 PM
Installing Sirius Satellite Radio: Need advice DieselFitter Car Audio and Multimedia 3 07-08-2004 05:11 PM
installing 500E suspension in W124T LuckyE320Wagon Performance Paddock 13 07-01-2004 08:13 AM
need guidance for installing W201 euros cossie Tech Help 3 09-02-2002 05:44 PM
Installing new chrome hippie_elmo Vintage Mercedes 4 01-05-2002 03:30 AM

All times are GMT -4. The time now is 05:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page