Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-29-2001, 10:18 PM
Posts: n/a
E420 idle trouble

I'm driving a 94 e420 with approx 90000 miles. The idle has suddenly dropped off to near nothing. Showing about 200 rpm or less. Lights go dim, it is so low. No check engine light but the car will stall if the a/c is on. Does this sound like a sensor that i could change myself? Also the throttle has become very touchy, seems to have no reaction to throttle movement and then suddenly jump. Any ideas guys. Thanks
Reply With Quote
Old 12-30-2001, 01:50 AM
Registered User
Join Date: Nov 2000
Location: Los Angeles, CA/ Hilo, HI
Posts: 92
Have you checked your AC compressor? The compressor clutch could be dragging against the polybelt if it is seized up. I had a similar issue on a 190E. The AC compressor seized up and killed the engine whenever engaged and idle was down a few notches.
Also, you might want to take a look at the throttle valve, could be stuck due to dirt accumulation and need a cleaning.
Good luck!
81 300 SD grey/palomino 168K miles
84 190E 2.3 black/grey 64K miles (wrecked)
85 190E 2.3 maroon/palomino 92K miles
88 300E desert red/palomino 204k miles
(made to look like a '94-95)
92 400E desert taupe/creme beige 120K miles
(converted to 94-95 E420 looks)
Reply With Quote
Old 12-30-2001, 08:58 AM
Registered User
Join Date: Dec 2000
Posts: 368
Check your throttle actuator. You can try moving around the actuator cable as it idles. Sometimes they have internal potentiometer problems. Might be better to have a tech check it.
This is a common problem on these cars.

Reply With Quote
Old 04-10-2003, 09:56 PM
Registered User
Join Date: Apr 2003
Posts: 22
as a good newbie, i did a search and it brought me to this thread (and a couple others). my girlfriend's cousin is flat out sick of her 1994 E420 because it just stalls at random. she even GAVE it to her kids (30 somethings) and they don't want it.

so, from what i gather, i should first clean the throttle body. worst case is that i need a new throttle body. the car only has 29,000 miles on it. in a post, it says that the computer was not properly calibrated from the factory. does this cause the car to stall or just run rich? i hear chip talk going on here. this seems like a far cheaper idea than a reflashed ecu. or can i give my ecu as a core and get a "corrected" ecu pretty cheap?

wouldn't a rich running car eat O2 sensors and converters like no tomorrow?

can i get an aftermarket maf that could be calibrated to adjust the rich condition? we ford guys have pro flow, i even have on on my SHO.

i am learning that all cars are fairly similar. being this mercedes E420 and my SHO are both pre-0B2 (pre 1996), we have a lot in common. on my SHO, erratic idle can be caused mainly by the idle air bypass valve. it's a mechanical spring loaded sensor that continuously adjusts idle for smooth operation. problem is that as it gets old, the spring gets out of whack which results in erratic idle and stalls. i know my gf's 1997 audi A4 has an IAB, does this mercedes?

does this stalling problem result in erratic idle (jostling 250 rpm or so until stall) or does the car just flat out stall. if the car dies out of nowhere, can it be the cam position sensor or the crankshaft position sensor?

i am very eager to hear your responses. i sure hope i can nab this car as my SHO now has nearly 123,000 miles on the clock. time for a new sled.

see ya,
92 Ford Taurus SHO 5 speed
210.5 HP 196.4 LB Torque at the wheels
silver on gray with all options
ss y-pipe with high flow cats
PRO M 80mm MAF
Walbro 190lph fuel pump
Tokico struts
Eibach springs
sho shop motor mounts
edelbrock RPM
shonut aluminum sub frame bushings
26mm rear sway bar
sho shop sub frame connectors
Yokohama AVS ES100 225/55/ZR16 tires
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
ICV-what's it for? and can high idle hurt trans? gmercoleza Tech Help 10 11-18-2004 10:16 PM
'83 380 SL fast idle problem Dorbell Tech Help 3 08-23-2004 09:25 PM
1967 230s idle problem techrondon Vintage Mercedes 17 03-29-2004 10:25 AM
94 E420 stalls at idle!!!! chadman Tech Help 4 04-11-2003 10:59 AM
engine trouble picking-up from idle horloge Tech Help 0 02-02-2003 03:32 PM

All times are GMT -4. The time now is 02:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page