Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-09-2002, 12:23 PM
Posts: n/a
Post 1987 190E Starting Problem (Went die suddenly)


I have 190E, 1987 MB. It was running fine and yesterday suddenly engine stopped running while I was driving. When I try to start it, it cranks but doesn't start. Once it started but in about 2 seconds, it died again. What might be the problem? I am new MB user, so i really dont have any idea, whats going on! Can someone please help me! I would really appreciate your help.

Reply With Quote
Old 01-09-2002, 02:22 PM
yal's Avatar
yal yal is offline
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,704
Have someone kneel in front of the rear right wheel then start the engine. If the fuel pump is working you should hear it buzz on. Either way you should get it checked.

Fuel pump relay and OVP relay. Both relays can fail. These relays are located behind the plastic shield behind the battery. The OVP has a fuse on top of it that you should check and it usually is red. The fuel pump relay is a rectangular black box right next to it, unplug it and check for corrosion.

Also do a search here on all the above and you should get a lot of information.

Hope this helps.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190e starting problem 89 190e 2.6 Tech Help 16 02-08-2005 12:43 AM
190E climate control problem ibdegen Tech Help 3 08-16-2002 05:27 PM
Starting Problem w/ 190E 2.3L gards Tech Help 4 11-24-2001 04:58 PM
Help! 190E, 2.6, '89 acceleration problem Sam Tech Help 6 10-23-2001 09:13 PM
w201 190e 1990 starting problem fixed crhenkel Tech Help 3 05-18-2001 03:21 AM

All times are GMT -4. The time now is 12:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page