Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-24-2002, 07:00 PM
Subman's Avatar
Senior Member
 
Join Date: Apr 2000
Location: South Florida
Posts: 447
95 E320, Vibration, code 7 comes up on the computer.

The 95 E320 is vibrating very bad, the check engin light came on so I checked the computer and found that the 7 code came up. On JimF's page the 7 code is "Knock control output switch in ignition control module (N1/3) defective" and the remedy is to replace the N1/3 so my question is where is the N1/3, what does it do and what could have caused this problem, could water be at fault?
Thanks
Subman
__________________
Factory trained Mercedes-Benz Technician
Look At My Website
-2002 C32
(E420 has passed away)
The best way to contat me is e-mail.

Reply With Quote
  #2  
Old 01-24-2002, 09:25 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
Did you get the code 7 from the ign control module, or did you just get a code 7 from the led/sw on the N/59 diagnostic plug
[ emission codes} ???
Reply With Quote
  #3  
Old 01-24-2002, 10:43 PM
Subman's Avatar
Senior Member
 
Join Date: Apr 2000
Location: South Florida
Posts: 447
I got the code form the LED on the plug. By pushing it and watching how many times it flashed. I have foud out what the part is but I dont know how much it will cost or if I could, just clean the contacts on the plugs (on the control module) and see if that works.
Subman
__________________
Factory trained Mercedes-Benz Technician
Look At My Website
-2002 C32
(E420 has passed away)
The best way to contat me is e-mail.

Reply With Quote
  #4  
Old 01-24-2002, 11:10 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
Code 7 from the led/sw on the 16 pin diagnostic box simply codes that there is a fault in the ignition .
The specific ignition code of knock sensor circuit would be code
25.
So that can mean any ignition fault, from a bad plugs, coils , etc to a shorted Wire Harness [ might want to see if that has been changed]
Your car is Distributorless ignition and has 3 coils. [ each fires 2 plugs at once].
Because you mention engine vibrations, you may want to check
the plug as one bad can effect 2 cylinders [ symptom-shaking, misfiring eng. and code 7]
I also noticed you questioned if this could be water related.
Did you just clean eng with water?
The reason I ask is that the 104 engine has the plugs/wires
mounted in the "V" of the head between the cams and they are suseptible to water ignition shorting as the water goes right down to the plugs and can't get out. If that is the case [ just guessing here from your info] . pull the top cover for the plugs/wires, dry it out , reset the 7 code and give it a try. While in there, I would check the wire harness for bad insulation.
If you do have ignition module problems , then a scan for codes can be done to narrow it down, but the led you are using only
brings up emmission faults in general and pops the CK Eng lamp.
It does not go into each system for in depth diagnoses. That
is what the other 16 sockets are for .
Reply With Quote
  #5  
Old 01-24-2002, 11:44 PM
Subman's Avatar
Senior Member
 
Join Date: Apr 2000
Location: South Florida
Posts: 447
You are 100% correct I was looking at the wrong list of codes, (JimF's page dose not tell you what cars the codes are for) I have made this mistake once before. Can I ask you where you found your codes. As for the water I had just washed the car but I did not wash the motor. Ill check out the ignition system.
Thanks
Subman
__________________
Factory trained Mercedes-Benz Technician
Look At My Website
-2002 C32
(E420 has passed away)
The best way to contat me is e-mail.

Reply With Quote
  #6  
Old 01-24-2002, 11:58 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
I have codes from various places. If you email me . I will send the led/sw codes in jpg to you.

The codes for your car are slightly different in that you have the led/sw N/59 set up and the 94/95 E320 is both HFM EFI and
dist.-less ignition.

One niceity of the 16 socket box is that if you make your own led/sw set up [ see my archieves post ], you can enter the other sockets and get to the specifics....
Those code are completely different than the ck/eng built in led you are addressing.
The basic purpose of that led is to monitor ANY malfunction that will directly effect the performance of the Emmission system.
So when a mechanic want to know if your car will pass an
emmisison test, he just has to see if he gets a single flash....
if not, you are under arrest...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 E320 Code 6 Idle Problem 300EE320 Tech Help 29 10-14-2003 12:33 PM
Looking for color code on 98 E320 matrikxx Tech Help 4 09-29-2002 02:55 AM
Will driving with fault code 26 on 94 E320 cause a problem? neumann Tech Help 5 07-30-2002 07:15 PM
98 E320 Engin Vibration around 4200 RPM YickWo Tech Help 5 09-21-2000 09:20 PM
Code reader for 1995 E320 engatwork Tech Help 4 06-11-2000 01:13 PM



All times are GMT -4. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page