Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-14-2002, 04:00 PM
Registered User
 
Join Date: May 1999
Location: So. Burlington, VT
Posts: 78
300 E / feels like it is starving for fuel

My Benz is a 1989 300E with about 117,000 miles. Occasionally it feels like it is running out of gas or starving for gas. This happens most often when cold and accelerating right after starting but does sometimes happen on the highway usually after a sustained period of 70 mph (maybe a teeny bit more) and then decelerating. Last weekend I was on the highway and had the cruise set for 72. I slowed to about 50 and for the next 10 minutes or so, the car wouldn't accelerate normally. It eventually goes away but obviously something is wrong and I would like to fix it. Any ideas?? The first time this happened on the highway, I immediately replaced the fuel filter and it seemed better but has started to reoccur. It wasn't that long ago so I don't know that the filter had anything to do with it.
Thanks for the help.
Reply With Quote
  #2  
Old 02-14-2002, 04:46 PM
MIKE FREEMAN
Guest
 
Posts: n/a
Starving

Robi;
Sounds like fuel starvation alright!
Change the fuel filter first, if the problem persists then replace the pump(s)
M.f.
Reply With Quote
  #3  
Old 02-14-2002, 04:50 PM
agupta
Guest
 
Posts: n/a
My car (85 190E2.3) has a similar problem. It was very pronounced earlier - then the oxygen sensor was changed, and that smoothed it out 90%. But a little bit still remains. BTW, all standard culprits have been changed - cap/rotor, plugs, wires, injectors, filters, etc. One tech said its the mass air sensor - haven't gotten it changed yet as the problem has drastically reduced with the new oxygen sensor.

Hence I am curious to know the cause of this problem in your case - maybe it can help me solve my problem! BTW, is your gas mileage OK? Mine had dropped, but is back to almost normal with the new O2 sensor.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 300SDL Question Marcb Diesel Discussion 21 02-17-2010 08:17 PM
300 SDL vs. 300 SD ? Benster Tom Diesel Discussion 8 03-24-2004 12:02 AM
1998-99 300 td anybody have problems? grease lightnig Diesel Discussion 8 09-05-2003 02:22 AM
A few 1988 300 CE issues JeremyAllen Tech Help 27 04-26-2001 10:59 PM



All times are GMT -4. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page