Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-18-2002, 07:00 PM
Registered User
Join Date: Jan 2002
Posts: 177
Rough restart after driving

I know there are many post about the jetronic engine control system but i haven't been able to find anything that could help me with my experience which is as follows;

1. The car, 350sl/117 engine, cold starts right up with no problems and idles about 900 rpm until the engine is warmed up .

2. The idle settles in at about 700 rpm when warm before driving off after a cold engine start up. I can't seem to get it any higher.

3. After a drive to a destination and the car has sat for some time, about 20 min. for example, upon restarting the car, it does not want to idle.
I have to feather the pedal and or start to accelerate immediately to keep the car running. If I take my foot off the throttle the idle will drop to around 600 rpms or lower.

Does this problem sound farmiliar to anyone?
Coolant temp sensor maybe?
72 350SL #69
73 450SL Parts Car?
78 450sl Parts Car
79 450SLC - Sold
1985 280sl
87 190E 2.6 - Donated
90 300E-Junked
97 E420

Last edited by knarf; 02-18-2002 at 07:16 PM.
Reply With Quote
Old 02-19-2002, 07:24 AM
Registered User
Join Date: Nov 2001
Location: North Central Kentucky
Posts: 1,061
I'm not up on that model. What fuel system does it have? Is that the old CIS mechanical injection system? If so, on a VW I would look for a bad warm up presure regulator or aging ignition components. Does adjusting the idle screw on throtle body have any effect at all?
Reply With Quote
Old 02-19-2002, 09:00 AM
Mark Herzig's Avatar
Registered User
Join Date: Apr 1999
Location: Austin, Texas
Posts: 380
do you have similiar problems with the '79 slc? The reason I ask is that I am experiencing similiar conditions when the car has been driven heavily and then gets shut down for 5 minutes or so, and then I restart. It idles very low and dies if I don't give it some acceleration.

The '79 and '72 have very different fuel injection systems. My idle when cold is around 1200 and settles down to 750 when warm. This weekend I turned the idle adjustment screw 1/2 turn counter-clockwise. That seems to have helped.
Mark Herzig
1995 E300D 153K
1985 300D 142K (sold)
1979 450SL 122 miles (sold)
1992 500E 127K (sold)
1987 300SDL 132K (sold)
1986 300E 161K (sold)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
Rough Idle & the OVP.... gidpor Tech Help 13 01-06-2008 11:28 PM
A few questions regarding high altitude driving. David C Klasse Tech Help 11 09-12-2003 09:00 AM
Rough Running 280C - Help! americanrm Tech Help 0 08-23-2002 10:49 PM

All times are GMT -4. The time now is 08:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page