Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-21-2002, 08:24 PM
Registered User
Join Date: Feb 2002
Location: Bend, Oregon
Posts: 112
Please Help! Third brake light problem

Hi All-

I have a r129 500SL that has an interesting problem; while the rear brake lights function correctly, the entire third brake light bar does not illuminate. The bulbs appear intact.

Any thoughts or suggestions?

Reply With Quote
Old 02-21-2002, 10:27 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Sure, this is a super-common problem on 129's. The power or ground wire (or both) crack and open in the area of the hinge. It's on the right side hinge bar. You need to take the plastic trim off of that hing and expose the wiring in that area, you'll find it. Need to solder in some new wiring is all.
It doesn't indicate the fault on your bulb failure system because the center stop lamp is direct from the brake switch, doesn't come through the exterior lamp monitor control unit.
Reply With Quote
Old 02-22-2002, 12:28 AM
Registered User
Join Date: Feb 2002
Location: Bend, Oregon
Posts: 112
Thanks Gilly-

I tried your recommendation without luck. Anyone have any other thoughts/ideas?

Reply With Quote
Old 02-22-2002, 08:12 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
WE(dealer) always fabricate a new section of harness from the rt side of the fuel tank & run it into the deck lid as many times the wiring where the hinge pivots is stretched & a quick repair won't hold long.
YOU need to get into the harness beside the fuel tank.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
230SL Brake Problem Jim Villers Vintage Mercedes 11 08-16-2006 05:58 PM
76 450 brake warning light issue. jaluhn Vintage Mercedes 2 12-21-2003 12:22 PM
brake problem on the 500E? anyone else? hedpe Tech Help 21 04-21-2003 11:44 AM
ABS Light after applying brake -90 560SEL jbrady Tech Help 1 11-11-2001 07:10 PM

All times are GMT -4. The time now is 10:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page