Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-08-2002, 11:56 AM
Registered User
Join Date: Dec 2001
Location: LaPorte, IN
Posts: 400
Cruise control switch bad?

When first setting cruise on '89 560SEL, car accelerates until lever is pushed down, then speed settles where it was set. Also, after if I turn cruise off, it will not turn on again until engine is switched off and restarted. The resume function does seem to work after braking. Is this likely to be the switch, or some other part of the system. If it's the switch I'd like to change it when I replace the ignition switch which I know is failing. Thanks
Earl McLain
'02 C230 Kompressor
'89 560 SEL "Frau BlueCar" (retired April 2004)
Reply With Quote
Old 04-08-2002, 12:45 PM
jbaj007's Avatar
Registered User
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
I have '84 300SD with EXACT same symptoms. I phoned Peter? (at GDL) and he indicated CC ECU was the culprit and said to send it infor refurb. I may try the circuit board check and resolder route first. If anyone has had a "cure" for the "restart to reset" problem I'd be interested as well. Thanks.

The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need non-working climate control, temperature and cruise control modules mplafleur Tech Help 1 03-18-2007 06:24 PM
300 TD Cruise Control problem donehickman Tech Help 1 06-17-2004 04:01 PM
Cruise control retrofit Greg in Oz Tech Help 1 04-09-2003 12:39 AM
Cruise Control Supposedly never worked right on my car...???? 190D22 Diesel Discussion 7 12-28-2002 04:13 PM
83 300D Cruise Control rmmagow Diesel Discussion 1 06-20-2002 11:47 PM

All times are GMT -4. The time now is 08:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page