Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-17-1999, 06:02 PM
rolfe3
Guest
 
Posts: n/a
I have a 92 190E2.6 that has a slight stumble/roughness at idle that started 15k miles ago. The car has 75k miles now. I have changed the plugs with no change. Car runs fine and gas milage is good(24 to 28). No computer codes and egr is closed and not leaking. Idle speed is normal(700 rpm) and fuel pressure is 75psi and EHA current is at -3 to -5 ma when warmed up(I have sensor plate adjusted richer for a delta of -2ma from factory setup for faster starting @40k miles). I had replaced o2 sensor at 50k for surging at idle(cured). Any ideas of how to clear up this slight stumble would be apprediated.
  #2  
Old 03-17-1999, 11:05 PM
Benzmac
Guest
 
Posts: n/a
Engine mounts on this model are as critical for rough idle as engine fuel mixture. These engine mounts are hydraulic and contain fluid and check valves. THEY FAIL OFTEN!
  #3  
Old 03-17-1999, 11:24 PM
M.B. DOC
Guest
 
Posts: n/a
POSSIBLY THE FUEL INJECTORS HAVE A FAULTY SPRAY PATTERN OR INCORRECT OPENING PRESSURE. ALSO CHECK THE RESISTANCE VALUES OF THE IGNITION WIRE ENDS. SHOULD BE ABOUT 1K OHM FROM THE CAP TO THE PLUG CONNECTORS, ON EACH CYLINDER.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'83 380 SL fast idle problem Dorbell Tech Help 3 08-23-2004 10:25 PM
1967 230s idle problem techrondon Vintage Mercedes 17 03-29-2004 11:25 AM
380 Idle Control Valve Test ctaylor738 Tech Help 5 01-23-2004 02:33 PM
190E2.6 idle roughness and emissions issues Duke2.6 Tech Help 2 03-23-2003 11:30 PM
190E2.6 stumble at idle rolfe3 Tech Help 1 05-11-1999 10:00 PM



All times are GMT -4. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page