Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-05-1999, 12:25 PM
akprasad
Guest
 
Posts: n/a
THe cigar lighter in my 1987 420SL is non functioning, nor is any light that may be there to illuminate the ashtray. The fuse is OK. The only clue could be that when I pull the ashtray to open it, the whole ashtray comes out, i.e. the metal 'spring' is not retaining it.
Is there a lead that should plug into the ashtray to pwer it?
  #2  
Old 05-05-1999, 12:40 PM
MB STARS
Guest
 
Posts: n/a
Yes there is a connector (power & ground) right behind the ashtray holding bracket on left hand side.also the illuminate lite blub.
You have to remove the bracket (two screws) to find the connector & blub.
The ashtray only has spring contects.
  #3  
Old 05-05-1999, 12:45 PM
akprasad
Guest
 
Posts: n/a
Thanks MB Stars. Does the lead need to plug into the ashtray, or the bracket?
  #4  
Old 05-05-1999, 05:40 PM
bliang
Guest
 
Posts: n/a
The connection is actually to the bracket, and the ashtray has a contact that resembles a hinge track on the left. Be careful when you remove the ashtray bracket, since it can be tight within the console, and the two prongs can be ripped from the connecting wires in a >10 year old car (don't ask me how I know this... ).

------------------
  #5  
Old 05-07-1999, 06:35 AM
akprasad
Guest
 
Posts: n/a
Thanks for the warning! I have removed the ashtray frame and the connector is there and seems OK. I've cleaned up the contact points and they seem fine now. However inside the actual socket for the lighter it seems very yucky. Are there any special tips on how to clean that up? Or should I just wrap my finger in emery paper and rub away? Could that damage anything?
  #6  
Old 05-07-1999, 01:16 PM
kevinmcc
Guest
 
Posts: n/a
I've had the same problem on my 560. The problem is that the ashtray itself is not fully engaged in the bracket. It should "hook" in at the bottom, then rotate (close) into place. If the hooks on the bottom of the ashtray don't lock with the bracket, the lighter won't work.
  #7  
Old 05-07-1999, 01:49 PM
akprasad
Guest
 
Posts: n/a
The ashtray pivots fine but the metal tab at the back does not 'catch' it when I open it. The ashtray just pulls out of the console.
Does this tab have to make contact with something to complete a circuit of some kind?
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help wiring cigar lighter 87 300E DB87300E Tech Help 13 09-26-2012 11:38 AM
79 240D W123 cigar lighter not working mbzr4ever Tech Help 6 01-30-2005 05:22 PM
no cigar lighter power JHZR2 Diesel Discussion 5 04-24-2002 01:25 PM
400E Cigarette Lighter RossGard Tech Help 3 05-17-2001 10:11 PM
W107 420SL Instrument cluster akprasad Tech Help 3 05-08-1999 08:20 AM



All times are GMT -4. The time now is 07:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page