Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-31-1999, 03:02 PM
ECollier
Guest
 
Posts: n/a
I have a 1987 300E. The CC buttons seem to be having problems.

1. Off button won't stay off - A/C keeps cliking on and off repeatedly.

2. EC mode, (economy i think) which is suppose to be just air and AC, turns the AC compressor on. I can't seem to just get plain old air.

3. None of the other modes seem to make a difference. Air always comes out of the top defrost vent and the vents closest to the door. NOTHING ever comes from the center front vents. Its like its always on defrost.

Lukily, the temp gauge and fan speed work fine. I get both cold or heat depending on the temp I select and the fan slows down as it reaches its set temp.

Can replacing this CC module fix these issues?

Should I buy new or rebuilt?

If rebuilt, who should I use? I've heard the place in Florida is not too good.

Thanks in advance,

Eli
  #2  
Old 05-31-1999, 07:14 PM
Adamou
Guest
 
Posts: n/a
I had the same problem... It has nothing to do with the buttons. You have to replace a relay.

------------------
-------------------------------------
WEB Site : http://www.adamou.dpn.ch
A.S.C. 1999
-------------------------------------
  #3  
Old 05-31-1999, 09:59 PM
RBM
Guest
 
Posts: n/a
Adamou,
If you can't shut the system off with the off button, it would seem that the pushbutton unit would be the problem. Could you eleborate on which relay you are suggesting to be the culprit.
  #4  
Old 05-31-1999, 10:25 PM
Benzmac
Guest
 
Posts: n/a
I have used various new and rebuilt units with great results. It does sound as if yours is faulty. It is easy to replace so even if you did get a bad one from a rebuilder, you would be able to send it back for another with ease.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #5  
Old 05-31-1999, 10:26 PM
Benzmac
Guest
 
Posts: n/a
I have used various new and rebuilt units with great results. It does sound as if yours is faulty. It is easy to replace so even if you did get a bad one from a rebuilder, you would be able to send it back for another with ease.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #6  
Old 06-01-1999, 10:10 AM
Adamou
Guest
 
Posts: n/a
RBM : Actually I can't tell you which relay was faulty as I haven't replaced it myself
Sorry

------------------
-------------------------------------
WEB Site : http://www.adamou.dpn.ch
A.S.C. 1999
-------------------------------------
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W124 300e Climate Control Wheel Sticker BigRichard72 Tech Help 9 05-13-2013 10:29 PM
Successful Climate Control Button Unit Overhaul Ken300D Diesel Discussion 26 03-04-2004 12:28 AM
1992 140 Chasis Climate Control Bulb replacement turnne1 Tech Help 8 12-16-2002 10:52 PM
w124 94 E320 wagon climate control John Bobo Tech Help 1 04-01-2001 05:50 PM
W124 Climate Control Bryan Harter Tech Help 2 08-10-2000 12:22 AM



All times are GMT -4. The time now is 07:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page