Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-11-2002, 09:40 PM
Registered User
Join Date: Feb 2002
Location: Kingston NY
Posts: 114
Attn: hasman - 190e ?

Haasman, you stated the following in your techron post "The '87 190E 2.3 I have been looking at for my daughter has been running VERY poorly. We change the rotor, cap, plub wires, did the leaking water pump, changed the relay with the fuse in the top, bled the injector lines and even added a bottle of Techron.

Still ran VERY poorly. Then, something caught my eye on one of the great posts on this site: It said "add even two bottles of Techron if you think the fuel injectors are really dirty" .... so I did. I let the car idle for about 5 minutes. I raced the engine a little bit .... let it run some more. I brought the RPMs up to about 2,500 and then I heard a sound kind of like a soft "phlup" ... and WOW! The engine runs sweet and the terrible trans problems are no more. "

I am wondering what he terrible trans problems were? I have added the second bottle and have let the car run for a few minutes, no change. I am planning to let the car idle for 20 minutes or so tomorrow and then race it for a few minutes and see what happens.
Reply With Quote
Old 08-12-2002, 03:25 AM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
The trans problems were rock hard shifting. Wham, wham wham to the point where I was almost completely sure that I didn't want to buy the car.

Actually the first order of business was to figure out why the car ran so poorly. We did a compression test and I was surprised but it was very good: 190, 180, 175, 174. This car has 209k miles on it. I bled the injectors at the fuel distributor. (This can be VERY dangerous so be VERY careful and have a fire extinguisher close by). Best to have someone inside the car ready to kill the ignition while you do it. You have to pull the air cleaner off. Have rag handy to catch the fuel, but watch it because the intake will want to such it down into the engine.

On our car two of the four injector lines had crap in them and spurted out.

But .... this didn't help the running problem and it didn't help the shifting.

After the Techron double-dose I took it for a spin, hoping that I solved the engine part and then I would have to move over to figuring out what was wrong with the "slammin Trans".

I was astonished to find that it shifted great. I couldn't believe it. The shifting problem simply went away. I wish I could tell you why but I can't. My guess is simply not enough vacuum?

I would do just what you said: Put a double dose in, let it warm up and then drive it hard. Ideally up inclines where there are loads. Higher RPM driving as well (after warmed-up) it good. You want your injector pintels to get cleaned.

FYI-after you are sure the Techron cocktail has done its job, change your oil and filter as soon as you've run through the tank of the elixir.


It has been my philosophy, with the now eight used Benz that I have owned over the years, 1. if they have been well cared for before me .... that 2. they usually need small things, not the huge things. I know there are exceptions, but this has been my experience.

I buy well cared for cars. I want cars with long and complete service histories, ideally from day one. I don't want ones that have been messed with. Simply by the book.

Geesh, sorry about all this. I got on a roll. Hopefully this helped.

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Old 08-12-2002, 02:31 PM
Registered User
Join Date: Feb 2002
Location: Kingston NY
Posts: 114
Thanks haasman, I will try to dirve it around as you suggest. As always, your help is much appreciated.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page