Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 08-09-1999, 08:26 PM
Posts: n/a

My 1985 300CD has developed an annoying

habit of late. After 3 or four days of

driving or sitting (it doesn't seem to

make a difference), the battery runs down

and won't start the car. I have replaced

both the alternator and the battery (both

tested bad) and the problem persists.

I hooked up an ammeter between the

disconnected positive battery cable and

the battery post. The only draw was 2 amps

lasting for about 5 seconds out of every

30 seconds. I suspected that was the clock,

and disconnecting the fuse for the clock

circuit ended the draw. Please, this is

making me crazy!! Any helpful suggestions

you can make would be greatly appreciated.

Bosch certified DFI Tech
20 years experience
MBCA Member, Southern Stars
Old 08-09-1999, 08:46 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
It is somewhat common for the Pre-glow relay to stay on after starting the car. Since the glow plugs take about the same amount of current as the alternator can put out the battery will go dead. Other than testing the charging system after every start or disconnecting the glow plug harness, replacement is a good bet.


Old 08-09-1999, 09:23 PM
Posts: n/a
Rest current draw on this model should be no more than 30mA. 2a draw from the clock? This test is best done neg termal to neg post. Connect ampmeter leads then touch the termnal to the post for aprox 15sec. to cycle every thing off. Key out of ign and doors closed.
Good Luck.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
[HELP - ELECTRICAL] tracing battery drain / ammeter usage ard Tech Help 24 01-09-2007 10:16 PM
intermitent dead battery ("+*#!) MarkM Diesel Discussion 7 12-17-2004 08:11 AM
500E Battery Drain Problem Persisting charnett Performance Paddock 6 01-15-2004 02:08 PM
2.3 16V Intermittent Battery drain when driving, Alternator OK Village Idiot Tech Help 7 02-07-2002 10:30 PM
Battery Drain RUH52 Tech Help 3 04-30-2001 11:37 PM

All times are GMT -4. The time now is 05:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page