Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-14-1999, 05:39 PM
ivor
Guest
 
Posts: n/a
Tonight my c class simply would not start when turning the key starter motor would not turn over. 1st hunch is that the battery is dead but the lights horns and everything else seems tobe getting full power.I have managed to start it with jump leads,and have driven it afew miles but after letting it sit outside a hospital for forty minutes it refused to start again, so back to the jump leads and a very helpful smiling gentleman in a new Volvo got me on my way again .At home now after some further driving it has failed to start again. Do you think it is only the battery or could it be anything else - alternator -starter etc. I would really appreciate your advice service is hard to get here on a sunday.
  #2  
Old 08-14-1999, 11:50 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Hmmmm. The battery is first to come to mind because you drove it after the jump start. Turn on the dome lamp and start the car. After you disconnect the jump cables the light should be a little dimmer but not too dim, If it is really dim you might have a faulty alt. Or you can check at the battery with a multimeter and see if the voltage when the engine is running is 13 or higher.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car still won't start '87 300E ejsharp Tech Help 1 01-22-2004 11:34 AM
my car won't start jivadent Diesel Discussion 11 02-22-2003 12:54 AM
Car won't start! oasis100 Tech Help 16 04-17-2002 06:00 PM
Installed Performance Chip - Car Won't Start need2speed Tech Help 9 03-17-2002 08:55 PM
Remote Start won't work on my car....93 300D Gordinho80 Diesel Discussion 2 03-16-2002 11:38 PM



All times are GMT -4. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page