Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 08-28-1999, 02:39 PM
Amin Lalani
Posts: n/a
Recently I started having a problem with car. It is a 1982 and in most cases it works
great but I have run across two problems.

My first problem is when driving the car (before is has warmed up completely) the
car seems to lose power for a few seconds then goes to normal then loses power again. There is only a slight dip in power but I would like to get it fixed
before it gets worse.

In Febuary the injector nozzels were replaced as were the injector hoses.

My second problem is the stereo(original). It seems to lose all the
settings if the car is turned off for more than an hour. It used to be
longer but the time has been decreasing. Has anyone run into this
problem before. The great thing about it is that when I turn the car on
the stereo is on and the volume is really high. It helps me wake up in
the morning.
Old 08-29-1999, 08:59 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would start by replacing both of the fuel filters (both are available in the PartsShop to the left). While replacing the pre filter you should take off the fuel cap and blow some compressed air into the line from the tank to blow away any algea. Also you could try some redline.

The radio I think has a little battery inside of it that is bad.(if not could be a capacitor). In either case I would get a new radio from Alpine or Eclipse.


Old 09-07-1999, 08:24 PM
Amin Lalani
Posts: n/a
I replaced both fuel filters on Friday and also blew compressed air throught the hose. The car is running great now.

I was considering buying the Redline 85 plus and was wondering if there was a dicount for buying a case and how much it would cost to send it to me in Toronto.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
85 MB 300 DT - Power window switch Dcheng Tech Help 7 04-23-2007 03:43 PM
1992 MB 300 SE A/C Problems Ralph-Andree Tech Help 2 07-22-2004 06:48 PM
Freaky Friday--please help 1982 300 D studebaker Tech Help 0 04-19-2002 07:17 PM
300 e exhaust problems robbyd Tech Help 1 03-07-2002 06:11 PM
Problems to look for on '98 300 TD bobtaylor Mercedes Used Parts For Sale & Wanted 1 01-26-2002 01:37 PM

All times are GMT -4. The time now is 09:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page