Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-18-1999, 05:27 PM
mark
Guest
 
Posts: n/a
Hi, Ive got a 560SEL 1989. It has a cold miss that seems to go away when its hot. New injectors, different fuel distributor (used), new plugs. The air pump is disconnected. Very smelly when started cold but no black smoke. As it warms the miss disipates until when at its hottest (a/c blowing at idle, summer traffic) the miss is very slight. The miss is a constant when cold (feels like same cylinder). Compression check equals all cyl. between 155 and 168. Under full throttle no miss is detected. Have any ideas? Thanks, Mark
  #2  
Old 09-18-1999, 08:09 PM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935


Mark,

Probably an enrichment compensator. They're about $375 from an MB dealer.

------------------
Rgds,
Aaron Greenberg
MB technician
'67 250SE Cabriolet
'77 450SL
'79 6.9
'79 6.9
'80 300SD
'81 240D
'85 380SE
'89 420SEL
'93 300E 2.8
  #3  
Old 09-18-1999, 09:54 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
an enrichment compensator on an 89 560? Hmmmm I'll have to think about this one. I would think that maybe lambda is a bit off or there is an air leak below the manifold.


------------------
Benzmac:
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM

Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
I finally got my 560SEL backstage1 Tech Help 12 11-09-2004 10:14 AM
Who has a 86-91 560SEL? Highest mileage? 86560SEL Tech Help 17 03-05-2004 02:12 AM
Rim offset help 560SEL cgoodwin Wheels & Tires 1 02-01-2004 09:05 PM
Any difference in wheels of 1989 & 1987 560SEL? stanigu Wheels & Tires 2 10-23-2003 12:29 AM
560SEL Running HOT - UPDATE-POSS. SOLUTION FOR OTHERS!! moedip Tech Help 6 04-04-2002 10:54 AM



All times are GMT -4. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page