Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-07-2003, 01:55 AM
Posts: n/a
Alarm problem Please Help

I changed the battery in my 94 s420 and now the alarm that never worked before comes on when I try to start the car. It doesnt come on when I open the doors.The door and trunk locks are not disabling the alarm. Power locks dont work on my car so I dont know if thats why its not disabling by the door locks.Someone told me a fusemay have blown do to me jump starting my car prior to me getting the new battery. A fuse was blown in the trunk compartment but I replaced it and still the car wont start just blinking lights. It doesnt even attempt to start when I turn the key. How can I disarm the alarm I will disarm it completely if need be? Or any ideas on what may be making it go off.There is a little wire that is connected to the negative side of the battery(not sure where it goes)that is cut could that be it.
Reply With Quote
Old 01-07-2003, 09:13 AM
Registered User
Join Date: Aug 2001
Location: Virginia
Posts: 19
You may have damaged the alarm module when you jump started the car. I hope I'm wrong.
I damaged mine (in my '90 300CE) when I gave someone a jump start. Shortly after the good samaritan act the alarm would go off for no apparent reason. I checked out all of the door switches etc. but everything looked OK. So I bit the bullet and took it to the dealer who replaced a fried alarm module. (about $ 400 as I remember)
That was the last jump start I will ever give with a Benz.
1990 300CE-24 (Gone but not forgotten)
2002 SLK 32 AMG
2002 ML320 (Gone)
1995 E320 Cabriolet
Reply With Quote
Old 01-07-2003, 11:23 PM
Senior Member
Join Date: Sep 2002
Location: New Jersey, U.S.A.
Posts: 2,398
If you give someone a jump with a Benz, do it with the engine off and the key out!
Reply With Quote
Old 01-08-2003, 10:15 PM
Posts: n/a
Good info ILUVMILS
Reply With Quote
Old 01-10-2003, 10:39 AM
Registered User
Join Date: Jan 2003
Location: london
Posts: 17
Re: Alarm problem Please Help

You will find 2-off fuses for the alarm module located in the rear fuse box. The alarm module is located in the trunk behind the rh panel, it is a white box with one plug. Remove the plug and remove the module. It is possible to take the cover off the module in which you will find a circuit board with 2 black relays, one operates the door locks and the other the alarm. The relays do tend to stick so try spraying them with some switch cleaner. If the circuit is burned out you will probably have to replace.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page